How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask mndave0002 Your Own Question
mndave0002, engineer
Category: Dodge
Satisfied Customers: 528
Experience:  Design engineer and toolmaker mechanic previous ASE mech and ICARE body man
Type Your Dodge Question Here...
mndave0002 is online now
A new question is answered every 9 seconds

How do i reset my van to turn off the limp mode

Customer Question

2000 Plymouth Voyager 3.0L
changed tranny fluid and filter
replaced trans shift solenoid
erased codes with scan tool, after driving through all gears, light comes back on then goes back to wont shift past 2nd
codes on trip meter say 55 then 23 and keep repeating
is there something else wrong i have no idea what it could be
codes that come up on the scan tool were P0731,P0733,P0734
fluid level is fine
Submitted: 8 years ago.
Category: Dodge
Expert:  mndave0002 replied 8 years ago.

Welcome to

Here is what your codes meen

55 is test done

23* Incoming air temperature sensor may be bad

  • P0731 Incorrect 1st Gear Ratio
  • P0733 Incorrect 3rd Gear Ratio
  • P0734 Incorrect 4th Gear Ratio
  • the last codes were from scanner correct? and you have digital odometer correct?

    I would review the solenoid installation

    Hope this helps

    If this helps click accept thanks again David

    mndave0002, engineer
    Category: Dodge
    Satisfied Customers: 528
    Experience: Design engineer and toolmaker mechanic previous ASE mech and ICARE body man
    mndave0002 and 3 other Dodge Specialists are ready to help you
    Customer: replied 8 years ago.
    Reply to mndave0002's Post: i checked the solenoid, and all 3 bolts are tight and the wire harness bolt is tight and secure, is there a fusible link or relay that is before the solenoid not letting it get power or something
    Customer: replied 8 years ago.
    Relist: I still need help.
    I made sure the 3 bolts holding the solenoid were tight, the wiring harness bolt is tight and secure, removed battery cable for 30 min, hooked it back up and drove it 1 mile and light service engine light came back on and went back into limp mode (2nd gear)wont shift higher than that
    Its like its in Low
    Expert:  William D Mulneaux replied 8 years ago.

    Welcome to Just Answer,

    Are these the same codes that prompted you to replace the solenoid?



    The highlighted relay and fuse control power to the solenoid pack. You can replace the relay with the horn relay for testing purposes. Replace the EATX relay with the horn relay. Completly clear the memory by disconnecting both battery cables and holding them together for about 30 seconds. Test drive and see if the light returns.

    Diagnosing is made simpler simple because the vehicle turns on the MIL and goes into limp-in almost instantly, you will no if it is fixed.

    Most often I see problems with the wiring to the solenoid. Inspect the harness for any chafing, this can be hard to track down. If you have an ohm meter and are comfortable with doing some trouble shooting I will be happy walk you through it.

    Good Luck,


    Customer: replied 8 years ago.
    i took it in to the dealer and they reprogrammed the computer and had to replace the output and input speed sensors on the tranny and now it is back to normal

    Related Dodge Questions