How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Construction and Road Equipment
Satisfied Customers: 989
Experience:  Technican turned service manager with multiple lines of equipment and rental units.
30244710
Type Your Construction and Road Equipment Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

We have a TH580B telhandler that suddenly had all the

Customer Question

Hi,
We have a TH580B telhandler that suddenly had all the hydraulics stop. It was running fine, put in neutral for about 5 minutes (without turning off the engine) and then the hydraulics won't function.
The power steering and all hydraulic functions do absolutely nothing.
I've measure the pressure at the ports on the main spool valve manifold. It's about 100 PSI in idle, going to 140 PSI with the engine running fast. It's about the same on all three ports and I don't have a manual to know what they do.
What's the most likely cause, and what should those pressures read?
Thank you!
Noah
Submitted: 4 months ago.
Category: Construction and Road Equipment
Expert:  Bradley Martin replied 4 months ago.

What is your serial number? sounds like a safety switch not engaged or something engaged on the dash is there any switches that are pressed that dont need to be

Related Construction and Road Equipment Questions