How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Bradley Martin Your Own Question
Bradley Martin
Bradley Martin,
Category: Construction and Road Equipment
Satisfied Customers: 173
Experience:  Field Technician at Thompson Tractor Company
29889544
Type Your Construction and Road Equipment Question Here...
Bradley Martin is online now
A new question is answered every 9 seconds

I have a 1997 beaver Monterrey RV with a 3126 cat diesel. I

Customer Question

I have a 1997 beaver Monterrey RV with a 3126 cat diesel. I can't seem to get it started
Submitted: 6 months ago.
Category: Construction and Road Equipment
Expert:  Cat Man replied 6 months ago.
Thanks for asking your question. I will try and help you out.
Does the engine spin over but not start?
Does the yellow check engine light come on when the key is turned to the on position?
Customer: replied 6 months ago.
There is a red "engine warning" light on and a red "park brake" light on when the ignition is in the on position. When the ignition is turned off a red "do not shift" light comes on. The engine will not crank with the key but will crank with the remote start button. The engine will run for just a bit with starting fluid. I don't see a yellow light
Expert:  William Herren replied 6 months ago.
Hello my name is***** will be assisting you. Can I please have your engine serial number.
Customer: replied 6 months ago.
1WM09316
Expert:  William Herren replied 6 months ago.
Did it just start doing this or has it been like this?
Customer: replied 6 months ago.
The RV has been sitting for 2-3 years. It started ok then but not now. We have new batteries and clean terminals. Thanks
Customer: replied 6 months ago.
I got it to run for just a bit on starting fluid and the tachometer did not respond. The gauges appear to be responding
Customer: replied 6 months ago.
The Allison transmission control panel doesn't seem to have power
Expert:  William Herren replied 6 months ago.
Will you please check the fuses at the battery box. Be sure to use a test light and test both sides of the fuse, also take a multimeter and take a reading where the power comes in to the inline fuse holder with the fuse removed.
Customer: replied 6 months ago.
Checked all fuses, circuit breakers, relays, and solenoid in the battery box and the electrical box and measured close to 12.6V every where.
Expert:  William Herren replied 6 months ago.
Do you have an Allison black box in your electrical compartment? Also, can you locate the relay for your Allison transmission?
Customer: replied 6 months ago.
There is a black box in the electric box and it says that there is a relay
Expert:  William Herren replied 6 months ago.
Can you verify that connection 85 is power(12volts) and 86 is ground?
Expert:  William Herren replied 6 months ago.
Or please send pic
Customer: replied 6 months ago.
Could not find 85 or 86. The Allison transmission model is MD3060
Expert:  William Herren replied 6 months ago.
Can you please send pic of the electric box
Customer: replied 6 months ago.
The box with 6 relays and 2 fuses has a model number 29509886. I moved all 6 relays around and it didn't seem to change anything. Both fuses have 12.6V on both terminals.
Customer: replied 6 months ago.
The control box ecu has a part number 29524778 and it has 2 connectors with about 30 wires each
Expert:  William Herren replied 6 months ago.
Thank you for the information. I am trying to assist you. I don't know your skill level, 85 and 86 are common circuits in every relay. When I request a picture it is so I can mark it up with instructions as to what to do and send it back.
Customer: replied 6 months ago.
I will get a picture of the electrical box tomorrow.
Customer: replied 6 months ago.
Oh, got ya. I will see about checking 85 86 on the relays too. Thanks for the help!
Expert:  William Herren replied 6 months ago.
Thank you, ***** ***** 5 stars
Customer: replied 6 months ago.
Here is a pic of the Allison electrical box with one relay out. The relay has been put back
Customer: replied 6 months ago.
Here is the electrical box items
Customer: replied 6 months ago.
If there is a particular relay for the transmission, I don't know where it is
Customer: replied 6 months ago.
Electrical box. The main relay on the two electrical bars works fine. All circuit breakers on the bars have power out
Customer: replied 5 months ago.
Are you still there?
Expert:  William Herren replied 5 months ago.
I apologize, when you don't respond for several days it's hard for me to help. I will opt out so another professional can help you.
Expert:  Bradley Martin replied 5 months ago.

Hello

I will assist you with your issue. If I am understanding correctly you still do not have power going to the transmission control unit where the relays are am I correct?

Customer: replied 5 months ago.
Can we get another tech or a refund? Thank You

Related Construction and Road Equipment Questions