How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dan Your Own Question
Dan, Technician
Category: Construction and Road Equipment
Satisfied Customers: 4291
Experience:  17+ yrs. shop and field experience with all major brands of heavy equipment and trucks - 1995 WyoTech graduate.
Type Your Construction and Road Equipment Question Here...
Dan is online now
A new question is answered every 9 seconds

I have a 2015 terex texoma 330 that has a trans psi fault on

Customer Question

i have a 2015 terex texoma 330 that has a trans psi fault on the display. the auger info says that the trans psi is 400 and the temp is 120 degrees f. is there a way to reset or to calibrate this issue
Submitted: 5 months ago.
Category: Construction and Road Equipment
Expert:  Dan replied 5 months ago.

Hi Guy, My name is***** will be glad to try to help. If the sensor and harness are good then be sure to verify it is not an actual fault. Check the filter and oil condition for signs of an internal/mechanical failure occurring. Look for fine metal/debris and for discolored or burnt smell in the oil. If all checks okay the dealer diagnostic software will be needed to check and monitor the parameters and run through the calibrations and potential software updates. Let me know.

Expert:  Dan replied 4 months ago.

Hi, Did you get this resolved?Let me know. If so, Please take a moment to rate my service as that is how the site credits the experts for their time helping on the site.

Related Construction and Road Equipment Questions