How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dan Your Own Question
Dan
Dan, Technician
Category: Construction and Road Equipment
Satisfied Customers: 4657
Experience:  17+ yrs. shop and field experience with all major brands of heavy equipment and trucks - 1995 WyoTech graduate.
65405794
Type Your Construction and Road Equipment Question Here...
Dan is online now
A new question is answered every 9 seconds

2005 pc160-7 low charge indicator (red battery) on the monitor

Customer Question

2005 pc160-7 low charge indicator (red battery) on the monitor all the time. new batteries
installed not long ago and the charge rate when running shows 28.5 volts. I would like to get rid of the red indicator and get the hyd. temp gauge back. how would I do that???
Thanks
Al
Submitted: 10 months ago.
Category: Construction and Road Equipment
Expert:  Dan replied 10 months ago.
Hi my name is***** will be glad to try to help.Clean/inspect/ tighten all battery to starter connections including all grounds. check all alternator connections and have the alternator tested for potential internal problems and voltage regulator problems. It is possible for the alternator to show a charge but give a false reading. If ok take a very close look at the harness and connector pins for corrosion, shorts, opens, or damage. Let me know
Expert:  Dan replied 10 months ago.
Hi, Did you get this resolved?

Related Construction and Road Equipment Questions