How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Construction and Road Equipment
Satisfied Customers: 26029
Experience:  Technican turned service manager with multiple lines of equipment and rental units.
30244710
Type Your Construction and Road Equipment Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

I have a Takeuchi TL140 2006 model. It would not start

Customer Question

I have a Takeuchi TL140 2006 model. It would not start without using starting fluid but once it starts it runs fine. Sometimes under heavy load it shuts off also. If I run it for a while and shut it off, it will start without starting fluid immediately but if I stop running it for more than 5 minutes, it would need starting fluid again. Fuel injectors were replaced as well as fuel filter and the injector pump seems to be running OK. We also tested the glove plugs and they are all fine.  Someone told me it is the Diesel valve control.

Submitted: 7 months ago.
Category: Construction and Road Equipment
Expert:  Curtis B. replied 7 months ago.
You do have full battery voltage to the glow plugs? Have glow plugs been replaced? If glow plugs are actually working, compression may be too low for good start. The glow plugs can be removed, and a compression gage installed and the compression tested. To check the fuel shutoff, remove it and see if engine starts.
Customer: replied 7 months ago.

There is full battery voltage to the glow plugs and they all work fine. The compression test was done and it is also good compression. what exactly do you mean by fuel shutoff?

Expert:  Curtis B. replied 7 months ago.
The injection pump has an electric fuel solenoid that has to open the fule, and close the fule when key is turned off. It will be electric solenoid, either in the injection pump, or mounted just t the left of the injection pump. It has to have battery voltage as soon as the key is turned on.
Customer: replied 7 months ago.

is that the same as diesel control valve?? If yes, what is the part number or an image for TL140 Takeuchi 2006 model

Expert:  Curtis B. replied 7 months ago.
177 shows to be the fuel solenoid , It looks to be external. Does it move the fuel rod as soon as key is turned on? See attached.
Customer: replied 7 months ago.

I will check that on Monday and let you know. If the solenoid is OK, is there anything else I should check or might be wrong?? Is there anything else you can think of so Ic an check while I am at it??

Customer: replied 7 months ago.

BTW, Is there a fuse or relay associated with that??

Expert:  Curtis B. replied 7 months ago.
Yes, it would have a fuse and likely a relay. But it would have to have voltage. so I don't see either fuse or relay problem/
Customer: replied 7 months ago.

Will check that on Monday. What if the Solenoid is working?? Anything else I should check while I am at it?? Anything else could be wrong??

If the solenoid is bad or stuck in off position, wouldn't you think that it would not continue to run after using the starting fluid to start the TL140 machine?? I can shut the machine off and if I try to start it immediately it will start without starting fluid but if I wait for 3-5 minutes, I have to use starting fluid again.

Is there anything else I should check???

Expert:  Curtis B. replied 7 months ago.
You already checked the glow plugs and the compression, only thing left would be the injection pump itself!
Customer: replied 7 months ago.

I tried the solenoid and it does work, there is power to it and it does function when the key is turned on. Also checked the compression again and all 4 cylinders are between 77-84. What else could be causing the issue??????

Expert:  Curtis B. replied 7 months ago.
compression on a diesel engine should be above 300 psi.??? Was this not psi?
Customer: replied 7 months ago.

Hi again, I had a diesel mechanic tested the compression and he said it is good. we also looked for the solenoid and there is no such thing in that TL140. There is a small little pump which we also replaced to ensure there is enough pressure but so far have the same issue.

Related Construction and Road Equipment Questions