How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dan Your Own Question
Dan
Dan, Technician
Category: Construction and Road Equipment
Satisfied Customers: 4754
Experience:  17+ yrs. shop and field experience with all major brands of heavy equipment and trucks - 1995 WyoTech graduate.
65405794
Type Your Construction and Road Equipment Question Here...
Dan is online now
A new question is answered every 9 seconds

I have a '90? Cat e70. Everything worked fine when I parked

Customer Question

i have a '90? Cat e70 b. Everything worked fine when I parked it one week ago. I started it yesterday, The temperature was was minus 6. The left track and swing do not work?
Submitted: 1 year ago.
Category: Construction and Road Equipment
Expert:  Dan replied 1 year ago.

Hi Rene, Usually when you loose half your functions it is an indication of one half of your pump failing or one side is not getting signal pressure to stroke the pump to full flow.A quick initial first check would be to check the in tank hydraulic filter for fine metal/debris indicating a pump or component failure. Let me know

Customer: replied 1 year ago.
I checked filter no metal
Expert:  Dan replied 1 year ago.

Ok, Check the signal pressure to the pumps and verify both pumps are getting signal pressure to the pump control valves when the functions are operated.... Check your pilot pressure. Its usually in the range of around 550-600 PSI

Expert:  Dan replied 1 year ago.

Is the hydraulic oil milky at all?

Customer: replied 1 year ago.
I can't check that until this weekend we'll talk then? I was thinking something electrical because it worked fine when I parked it
Customer: replied 1 year ago.
no milky hyd.
Expert:  Dan replied 1 year ago.

That will be fine. My daughter is visiting this weekend so it will likely be late night or mornings I will be free

Customer: replied 1 year ago.
ok
Expert:  Dan replied 1 year ago.

We can post back and forth as needed.

Customer: replied 1 year ago.
I have removed and taken apart the pump. I need parts. One on the plates the plungers go through is cracked and bent.The pump is an Uchida Hydromatik. Model A10VD43SR1S5-995-4. Do you know where I can get them?
Expert:  Dan replied 1 year ago.

Hi Rene, Did you get this resolved?

Expert:  Dan replied 1 year ago.

Hi, Did you still need help with this?

Related Construction and Road Equipment Questions