How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Bradley Martin Your Own Question
Bradley Martin
Bradley Martin,
Category: Construction and Road Equipment
Satisfied Customers: 175
Experience:  Field Technician at Thompson Tractor Company
29889544
Type Your Construction and Road Equipment Question Here...
Bradley Martin is online now
A new question is answered every 9 seconds

I have issues with a caterpillar 953c loader left turn

Customer Question

i have issues with a caterpillar 953c loader
left turn steering is all or nothing once oil is warmed up.
right is not so bad. showing codes
30-96.03
30-248.02
079-110.03
079-135.07
079-190.08
079-469.12
079-470.12
079-471.12
079-472.12
Also has issues with the loader lift and tilt circuits...all hydraulic functions seem to only begin to work once rpm is at least half throttle. loader creeps fairly quickly.
also when the loader is lowered rather quickly it will act as if a safety check? slows it right down. Any help on this?
Submitted: 1 year ago.
Category: Construction and Road Equipment
Expert:  Bradley Martin replied 1 year ago.

Hello my name is***** will be helping you. The codes you have listed indicate a major wiring harness damage. I would inspect your wiring harness from the monitoring system down and look for rubbed wires or shorted wires. once you repair the shorted wire those codes will probably go away. If you don"t want to repair the harness if you can give me your serial number I can look up the part number for a new wiring harness.

Customer: replied 1 year ago.
ok I will check the harness...serial number is ***** when traveling faster than half speed the machine will lock up and transmission light will flash on dash...wait a few seconds and off you go again. I adjusted track speed sensors and the left side was out a fair amount...loader relief (main) had a tiny piece of metal stuck in it and one cylinder was leaking badly inside so I think the loader will be much better but havent tried it yet. the machine will track fairly straight so I dont think there is a bad pump or motor in hydrostat, wasn't sure if there was a calbration for the electric pedals or something along those lines that may be a cause?...It is the strangest hydrostatic system I have ever seen, way more complex than needed.
Expert:  Bradley Martin replied 1 year ago.

This should help you let me know if you need anything else

Expert:  Bradley Martin replied 1 year ago.

Here is another calibrations document I found

Customer: replied 1 year ago.
Another question same machine. Is there any way to tie in to the loader hydraulic circuit to add another bank of hydraulic valves? Any ports on the reservoir that can be used for power beyond somehow?

Related Construction and Road Equipment Questions