How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dan Your Own Question
Dan
Dan, Technician
Category: Construction and Road Equipment
Satisfied Customers: 4381
Experience:  17+ yrs. shop and field experience with all major brands of heavy equipment and trucks - 1995 WyoTech graduate.
65405794
Type Your Construction and Road Equipment Question Here...
Dan is online now
A new question is answered every 9 seconds

I HAVE A 2007 426 WHEEL LOADER THAT STARTS FINE AND WHEEN

Customer Question

I HAVE A 2007 426 WHEEL LOADER THAT STARTS FINE AND WHEEN YOU GO AND STOP AND LIKE CHANGE BUCKETS AND START AGAIN IT DONT GO FOWARD OR REVERSE AND ON THE DASH IT DONT SAY N FOR NEUTRAL OR F OR R REVERSE . THAT HAPPENED COUPLE DAYS AGO AND WAITED BOUGHT 30 MIN AND WENT BACK TO IT AND STARTED AND DROVE FINE AS LONG AS YOU KEEP DOING WHAT U ARE DOING. ITS LIKE ITS NOT GETTING A CODE ABOUT IT BEING IN PARK TO CRANK
Submitted: 11 months ago.
Category: Construction and Road Equipment
Expert:  Dan replied 11 months ago.

Hi my name is***** will be glad to try to help. Check for power in and then out of the shift controller in each gear position to the shift solenoids and inspect the harness and connector pins for corrosion, poor connections, and damage. The shift controller is a wear item and it is possible the contacts inside are worn. Also, check the filter and oil for signs of fine metal indicating an internal mechanical problem. Let me know

Customer: replied 11 months ago.
can u help me further no help so far
Customer: replied 11 months ago.
oil is fine clean and filter clean . the loader did the exact same thing when they brought it to us the dash should tell u if it is n neutral or park and its not . I don't know if something is telling it that its in gear or what
Customer: replied 11 months ago.
loader don't have but 1200 hrs on it pins in the connectors should not be worn
Expert:  Dan replied 11 months ago.

Hi Lee, Not true. Harness connections can fail at any time. I was field service for Cat, worked at a JCB, Komatsu, Deere, and Volvo dealer in the past before going independent. I have seen brand new machines under their 6 month warranty have poor connections in the harness, shorts, Rubbed through wiring, prematurely failed shift controller and electrical components. Age has no bearing on this. The machine is 9 years old. Has it ever been used in the salt for snow removal etc. in its lifetime? Pressure washed with high pressure steam cleaning and chemicals? There are many factors. You need to test for power with a test light into the electronic shifter. Then test for power out of the shifter for each gear position and when this occurs, verify it again to see if it is loosing power out of the shifter when the problem is present and if so.... The power in is good but nothing out when the problem exists, It is a faulty shift controller. It is common. Let me know the results of the tests

Customer: replied 11 months ago.
IT HAS BEEN PRESSURE WASHED CAUSE IT WAS USED IN A TURKEY HOUSE PUSHING WASTE UP. AND THE PLACE WE BOUGHT IT FROM DID PRESSURE WAS IT ALOT TO GET OFF THE WASTE
Expert:  Dan replied 11 months ago.

Look inside the electrical connectors for corrosion as high pressure water can enter the connectors and get stuck in them causing corrosion. If clean, Install dielectric grease in the connectors. If corrosion is found, repair the connector. They sell the weatherproof connector pins, crimp tool and plastic housings if needed.

Expert:  Dan replied 11 months ago.

HiCustomer Did you get this resolved?

Related Construction and Road Equipment Questions