How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dan Your Own Question
Dan
Dan, Technician
Category: Construction and Road Equipment
Satisfied Customers: 4679
Experience:  17+ yrs. shop and field experience with all major brands of heavy equipment and trucks - 1995 WyoTech graduate.
65405794
Type Your Construction and Road Equipment Question Here...
Dan is online now
A new question is answered every 9 seconds

komatsu d66s-1 rear engine track loader. all functions

Customer Question

komatsu d66s-1 rear engine track loader. all functions work except machine will not move. I think its an electrical issue. computer panel lights are going on and off. power seems to be there . I was thinking maybe poteniameter  control  bAll I know it needs to be a komatsu mechanic who knows these machines. thanks Bill

Submitted: 1 year ago.
Category: Construction and Road Equipment
Expert:  Dan replied 1 year ago.

Hi my name is***** will be glad to try to help. What is your serial number?

Customer: replied 1 year ago.

Hi Dan sorry I just saw your email.ser# ***** I have the parts and service manuals for this machine. Machine always seemed to have little electrical issues. Machine would run great, fast all kinds of power then out of no where tracks would stop dead red light would flash buzzer going off. Then I would lower engine to idle cycle key off and on then light and buzzer would stop going off and machine would operate normally. Figured it was electrical Issue. Then the trans conrol lever would do strange things machine would go then not go with out alarm sounding , figured maybe potentiometer was bad there are 4 of them that I know of on this machine.then last time i used it it came to slow stop. and that was it. still creeps backward when cold when in neutral

Expert:  Dan replied 1 year ago.

Thanks for the update. The first thing I would check on this is for low voltage. Test the batteries with a digital tester for their internal condition for dead cells etc. If they pass, clean all the terminals between the batteries and starter as well as all chassis grounds. Inspect the harness to the alternator as well for any damaged wiring and loose connections. Test the alternator and monitor the charging voltage to see if when this happens the charging voltage drops to battery voltage. Low voltage can cause your symptoms. Let me know the results and if we need to dig deeper into this.

Expert:  Dan replied 1 year ago.

Checking for low voltage is the first step. If that tests OK we will need to look into testing the fuses/relays, harness for corrosion/loose connections and damage, faulty shift controller, solenoids, sensors/potentiometers and also check the oil for discoloration/burnt smell and filter/strainer for signs of metal indicating internal issues. Let me know

Customer: replied 1 year ago.

Hi Dan ,Thank you for responding I know low or no voltage is most likely the problem I had just put two new batteries in machine. guess I was hoping to find a komatsu mechanic who has had experience with this machine this is a common problem for this machine so I hear

Expert:  Dan replied 1 year ago.

Hi Bill, I was a technician at a Komatsu Dealer in the past as well as Volvo, John Deere, and Field service for Cat. I had the manual for this model on my file sharing site but it seems they deleted it possibly for copywrite issues. By chance do you have the manual handy? With the new batteries is the display panel still going in and out? Are you able to pull any error codes? Let me know.