How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Construction and Road Equipment
Satisfied Customers: 26030
Experience:  Technican turned service manager with multiple lines of equipment and rental units.
30244710
Type Your Construction and Road Equipment Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

I have a 2004 268B skid steer, every now and then it starts

Customer Question

I have a 2004 268B skid steer, every now and then it starts to loss power as if it was out of fuel I move the bucket dump and lift and it starts back up again. I have to keep doing that till it regains power again sometimes it dose it cold as soon as I turn it on and some times after it been running for Hrs. Today it won't start, it start with lots of black smoke for 2-3 seconds then it stops I checked the water separator it was full. I switched the gas relay on the upper 4 relays that operates the fuel pump. I also removed the air filter to make Shure it had air. Do you have any ideals
Submitted: 1 year ago.
Category: Construction and Road Equipment
Expert:  Curtis B. replied 1 year ago.

Do you have fuel getting to the injection pump? Has the fuel filter been replaced? Did you remove the fuel separator and clean it? Is the fuel shutoff solenoid at injection pump opening? It has to open as soon as key s turned on,

Customer: replied 1 year ago.
Good afternoon Curtis B. I checked the air filter and I looked for the diesel fuel filter and it doesn't have one, the water separator is the combo water separator / fuel filter, I called Quinn Cat co.. I cleaned out the electric fuel pump and housing and did find some debris in it.
I also changed the relay to the fuel pump. I open the end of the line at to the ports per say the injectors and fuel was pumping out. It starts up for 1-2 sec. with dark black smoke. I remove the 2'' hose that goes from the air filter to the intake manifold
and still black smoke. Do you think it might be my muffler? Curtis let me know if the attaché picture went thru, I just send that one as a test
Expert:  Curtis B. replied 1 year ago.

Yes, work site picture!

Customer: replied 1 year ago.
I can't call now I'm on the road and I prefer to continue with writing I will attach a short video regarding what it does I won't get back to you till tomorrow I'll send it first thing in the morning Thanks for your expertise
Expert:  Curtis B. replied 1 year ago.

Has the return been checked from injection pump back to tank?

Customer: replied 1 year ago.
I will ck later today . I'm going to he working on it all day tomorrow . I will also take video and send it to you
Expert:  Curtis B. replied 1 year ago.

OK, thanks.

Customer: replied 1 year ago.
Hi I think its a fuel pump I remove the hose that goes to the tank and put a clear hose to a five gallon diesel container and it doesn't suck it up very good I'm going to see about changing the fuel pump
Expert:  Curtis B. replied 1 year ago.

OK, good test.

Customer: replied 1 year ago.
Well Curtis, I worked on it all weekend. I removed the catalytic converter just in case if it was clogged and it continued to want to start but lots of black smoke. I changed 5 relays, 1 at a time, that may have gone out. I removed the air filter to give it as much air as possible. Then I Checked the Hydraulic fluid and it was a little low so I add some, then I did what I told you that worked at the beginning of this journey I start the Eng. and start to dump the bucket and raise it over and over then it starts to gain power and all of the sudden it got full power and it ran as if nothing was ever wrong. Well then I thought maybe it was the low Hydraulic fluid and some sensor shut the Eng. down but after 1 hr. it did it again and I dumped and raised then dump and raise and again it's working fine now. Do you have some one you can consult with. It has a pressure release switch to remove the attachments, I try that too and still the same,
Expert:  Curtis B. replied 1 year ago.

You have a hydraulic function that is loading the engine, that's why the smoke. One is staying engaged. Are all the spooling in the control valve coming back to the center position?

Customer: replied 1 year ago.
I'm not Shure what you mean. This is what think your asking, I lifted the cover to the toggle control for the bucket. I see four valve stems that the toggle stick flange push down on to lift or dump. I will check them today when I get home. I'll keep you posted.
Expert:  Curtis B. replied 1 year ago.

Ok, I 'm fixing to go on three day trip, be back late Friday.

Customer: replied 1 year ago.
Enjoy your trip, I'll keep working on it. I'll reply to you on Sat. with any new info. We will fix this skid steer I'm not giving up.
Expert:  Curtis B. replied 1 year ago.

OK, thanks!

Related Construction and Road Equipment Questions