How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask spankyjr1 Your Own Question
spankyjr1
spankyjr1, Journeyman
Category: Construction and Road Equipment
Satisfied Customers: 2515
Experience:  I worked on all types of equipment semis,forklifts,farm,ect.
65057319
Type Your Construction and Road Equipment Question Here...
spankyjr1 is online now
A new question is answered every 9 seconds

TL140 losing power under load even cutting out under extreme

Customer Question

TL140 losing power under load even cutting out under extreme load I have checked complete fuel system for blockages and water and this is what I have found. cloudy fuel, blocked filter in lift pump on injector pump, water in separator, debri in electric fuel pump filter I also have run a pressure gauge on low fuel pressure side and maintained 7-13 psi of pressure. I also have checked turbo pressure and it also runs about 7-13 psi. I am at the stage of removing injection pump and injectors to get tested. my only other thoughts are that maybe hyd filters are partially blocked, the hyd oil is on the brownish side but not sure if this could be the problem or not. I have just bought this machine it has 560 hours it and ran fine on flat ground at full revs struggles up hills and when cold
Submitted: 1 year ago.
Category: Construction and Road Equipment
Expert:  spankyjr1 replied 1 year ago.
Hi, my name is ***** ***** you for your question.
Sorry for long delay
Did you drain all bad fuel out of tank and fill with fresh fuel?
When checking fuel pressure to pump was that just sitting still at idle?
Or under load too?
Did you check to see if you had air in suction side of fuel system or return side?
Let me know
Customer: replied 1 year ago.
Yes I replenished fuel and checked pressures under load. I would imagine if there was air in the fuel system that there would be a low pressure reading and that engine would run rough. This engine does not blow any smoke or is not hard to start at all. The only smoke that is blown is on cold start up or when the engine stalls.
Customer: replied 1 year ago.
I must add if you are very gentle with the control levers and ease into a pile of dirt the machine will power on but cant handle too many functions at once such as crowding bucket lifting arms and reversing out of pile.
Expert:  spankyjr1 replied 1 year ago.
Sorry about delay,, had family functions today.
You can have good fuel pressure even if it's sucking air,, you must eliminate suction side to confirm that there is no air in fuel,, or you can use a clear hose before transfer pump and look for air in fuel.
You also have low boost which is from lack of fuel or a leak on anything from turbo to intake like a hose,,gasket,,clamps,, or bad cooler.Pressure check cooler and hoses for leaks on boost side.
Pressure and volume both need to be there or you will have low power.
If volume is low fuel gets hot and causes low power.
You can also get air in return side,,if you have air in return fuel you need injectors.
Combustion gas (air) can affect performance even if it has no miss.
I would not just throw parts at it,, you need to confirm you have a good suction and return fuel system.
I usually run both suction and return hoses out of a clean bucket of fuel with clear site glass,, you can use a clear hose if you don't have a sight glass.,,,,,,Make sure both hoses are in fuel not just dumping fuel in on return side so you know for sure its from injectors.
All your symptoms point to lack of fuel.
You may have a bad fuel pump or injectors considering you did find contaminated fuel but that's way to much money to throw at it and not fix the problem I have seen it happen dozens of times.
Questions or problems let me know I'm happy to assist.
A rating is required. You’re rating my personal service to you, not Just Answer. I am not an employee of this website, nor do
I have control over the fees or the time it took for you to get a response. I respond as soon as I see the questions in the order
that I receive them when I am online.
Also rating does not close your question, it just assures Just answer credits me,,, has nothing to do with you.You can continue
to follow up as long as needed even after rating
Thanks spanky
Expert:  spankyjr1 replied 1 year ago.
Hi I'm just following up to see if you where satisfied with my answer.
Please keep in mind that even though you have already paid your deposit money
over to JustAnswer, or you may be a subscriber, until you rate me highly for my service,
I will not be paid for having assisted you with your questions.
Thanks
spanky

Related Construction and Road Equipment Questions