How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask dd85 Your Own Question
dd85
dd85, Technician
Category: Construction and Road Equipment
Satisfied Customers: 497
Experience:  Service amanger for over 15 years
15057492
Type Your Construction and Road Equipment Question Here...
dd85 is online now
A new question is answered every 9 seconds

I have a 2002 new Holland ls 180 skid steer machine was running

Customer Question

I have a 2002 new Holland ls 180 skid steer machine was running fine was using it when it started to loose power I thought it was water in fuel I shut it down checked filter but notice lift pump wasn't buzzing with the key power on usually did. I thought it was lift pump I bought a new lift pump and filter changed it still no power to pump checked fuse's all good unless im missing some tried to trace wires to relays but get lost in harness pump wire is purple blue orange machine cranks and run on ether just no lift pump power what relays work that pump and what safety switch would kill that it was in use when pump lost power. I don't have 135.00 an hour for this simple wire problem what fuses relays and switches ignition switch is a little sloppy. thanks
Submitted: 1 year ago.
Category: Construction and Road Equipment
Expert:  dd85 replied 1 year ago.
For your LS180 fuel pump to run you have to be sitting in the seat, seat belt fastenedThe power goes through the interlock relay, Located behind the cab on the firewall. It is covered by a black plastic cover. I have attached a picture of the wiring.
Customer: replied 1 year ago.
So i should change the service switch relay i jumped power to the pump and pump runs
Expert:  dd85 replied 1 year ago.
Check power supply (5-ampfuse in cab panel). If not OK,check ground;
Expert:  dd85 replied 1 year ago.
power starts at the Service Run switch, then goes to the cab 5 amp fuse. then to fuel pumpI am attaching wiring pictures.
Expert:  dd85 replied 1 year ago.
another one. It is not the Interlock relay.
Customer: replied 1 year ago.
So ignition is good check 5 amp fuse and power to service run swicth so its either bad fuse bad service run switch or bad wire right
Expert:  dd85 replied 1 year ago.
I have attached how to check the Service / Run switch.