How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Leon Poston Your Own Question
Leon Poston
Leon Poston,
Category: Construction and Road Equipment
Satisfied Customers: 9
Experience:  Owner at Han-Liv Inc.
11213383
Type Your Construction and Road Equipment Question Here...
Leon Poston is online now
A new question is answered every 9 seconds

I have a cat generator set,xq30 4 it worked fine until last

Customer Question

I have a cat generator set,xq30 4 it worked fine until last week I went to service it,I started it it ran for maybe 3min, then quit,the control panel red failure to start. I reset it restarted sounded fine it ran for about a minute then quit again this time the indicator lamp that was on is the low coolant /high temo,but it never ran long enough to reach temp. All fluids are full and clean.
Submitted: 1 year ago.
Category: Construction and Road Equipment
Expert:  Leon Poston replied 1 year ago.
Hello
Have you checked your temp sensor?
Expert:  Leon Poston replied 1 year ago.
Have you checked the temp sensor?
Customer: replied 1 year ago.
We tested the sensor on the top.of the radiator, not sure if that's the correct one
Expert:  Leon Poston replied 1 year ago.
What cat engine does it have? There should be at least one, most cat engines have 2 coolant temp sensors on the top front of the engine that screw into the water jacket of the head.
Customer: replied 1 year ago.
This has a Perkins engine
Expert:  Leon Poston replied 1 year ago.
I will check tomorrow to be sure but it should be near the front. It could also be 8th the thermostat housing. I will let you know tomorrow.
Customer: replied 1 year ago.
Thanks,do you test these sensors as you would a automotive sensor. Is there a way to bypass it to make sure it will run if replaced?
Expert:  Leon Poston replied 1 year ago.
It depends, if the sensor is normally open you would want to unplug it and try it. If the sensor is normally closed you would want to jump the wires together and try. You can try it both ways. The worst that will happen is the machine will shut down.
Customer: replied 1 year ago.
I tried jumping the sensors unplugging the sensors and only miss answers I don't know that that's the problem but it still runs for a few minutes first time it will quit the next time it'll only run for like 45 seconds and then quit it doesn't even reach operating temperature thought enough I need to take it have it scanned for codes or there's another way to get codes out of it it's an 05 model sorry it took so long to get back I've been tied up with some other stuff
Expert:  Leon Poston replied 1 year ago.
I am not sure if there is a way to get flash codes... If you would like I will opt out and another expert may know how.

Related Construction and Road Equipment Questions