How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Construction and Road Equipment
Satisfied Customers: 988
Experience:  Technican turned service manager with multiple lines of equipment and rental units.
30244710
Type Your Construction and Road Equipment Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

My ls160 was running fine we had rain the past few days, this

Customer Question

My ls160 was running fine we had rain the past few days, this morning I sat on the seat and nothing lit up. When tryed to start it runs for a few seconds and stops. I checked the seat and seat belt switches and they are fine it will run in the service position. All fuses are ok. I cheched the display pin 14 has 12 volts as does pin 4. HELP !!!! :)
Submitted: 1 year ago.
Category: Construction and Road Equipment
Expert:  dd85 replied 1 year ago.
1. When you sit in the seat does the instrument cluster light up? 2. When you fasten the seat belt dioes the Seat belt light go off?3. When it shuts down are there any lights flashing on the instrument cluster?

Related Construction and Road Equipment Questions