How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Marco Your Own Question

Marco
Marco, IT Consultant
Category: Computer
Satisfied Customers: 688
Experience:  10+ years of experience as an IT Consultant.
72952988
Type Your Computer Question Here...
Marco is online now
A new question is answered every 9 seconds

new build no video but all fans turn on and mobo power light

This answer was rated:

new build no video but all fans turn on and mobo power light on board is on. case lights on but no vid. i think i need bios update but no video
asus mobo m5a97 le r2.0,
amd fx 8320 cpu
kingston hyperx ddr3 2x4gb(8 total)
asus geforce gt610
2tb wd sata hdd
lg blu-ray burner
thermaltake 600w psu
Hello and thank you for using this service,

Do you have a single post BEEP when you power on the computer?
Customer: replied 3 years ago.

no beeps and i tried 2 different speakers

Customer: replied 3 years ago.
Relist: Incomplete answer.
had difficulties and got the tech with the site corrected but never got an answer
Hi there,

Can you please try the following:

Remove the CPU, Clean the thermo if you used some. Place a small amount of thermo in the middle of the CPU and then reinsert the CPU on the motherboard. Turn on and then test.
Customer: replied 3 years ago.

i did that initially. im thinking well i know the mobo have a bios update and ive read that fixed the problem for some. i check the bios version and the asus website stated the board need a bios revision. but have no vid.

Yes you can't update the BIOS is it's not booting up.

Do you have another video card that you can test, this will confirm whether it's the video card or the motherboard/CPU as you have mentioned you have already tested the memory.

What video connector are you using for the monitor, is it VGA, DVI or HDMI?
Customer: replied 3 years ago.

the board has no onboard vid. and this is a new build. i tried all three ports, hdmi,dvi,and vga.really weird light on board works meaning psu works. optical drive powers up. all fans, (cpu and 2 system ) work


stuck a usb thumb drive in every usb port and all of them work.


 

Do you have another video card that you can use to install on the motherboard?

Although there is power, it just means that it's getting power to the motherboard but it's possible that the CPU is not working. The BIOS doesn't work if there is CPU, Motherboard or memory is not working. This is the minimum requirement to get to the BIOS so you can try to disconnect all other devices like the hard drive, CD rom and just have those 3 components.
Customer: replied 3 years ago.

SmileSmileSmile i dont have another vid card but push come to shove i have 15 day warranty so ill just take mobo and vid card back for exchange.

Make sure the video card is pushed all the way into the slot.

If you've already done that, I think it would be best to just get an exchanged.
Marco, IT Consultant
Category: Computer
Satisfied Customers: 688
Experience: 10+ years of experience as an IT Consultant.
Marco and other Computer Specialists are ready to help you

Related Computer Questions