How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Anthony Brewster Your Own Question

Anthony Brewster
Anthony Brewster, Consultant
Category: Computer
Satisfied Customers: 5365
Experience:  MICROSOFT PC SAFETY, WINDOWS LIVE ONECARE, WINDOWS GENUINE, & I.T. SPECIALIST
16299369
Type Your Computer Question Here...
Anthony Brewster is online now
A new question is answered every 9 seconds

on start up I got the following Rundll32 IEDKCS32.DLL,

Customer Question

on start up I got the following:

Rundll32 IEDKCS32.DLL, Brand IE4 Signup

I've already got RegCure and use it every day before closing down my computer. I ran it today 4 times one after the other cleaning and fixing the problems found. Am now undertaing a trojan scan and a microsoft scan.

Any ideas what's behind this as I've also got the following when installing programmes:

*.* is not a valid win32 application.

I've searched for help with this and found it may be a problem with Ahead Nero and taken steps to sort this out. As I cannot restart my computer at this time I've no idea if this has worked or not.
Submitted: 7 years ago.
Category: Computer
Expert:  Anthony Brewster replied 7 years ago.
Hello, are you running XP or Vista?
Customer: replied 7 years ago.
I'm runnning XP Professional
Expert:  Anthony Brewster replied 7 years ago.
PERFECT! This Rundll32 IEDKCS32.DLL is a rootkit (infection) and rootkits are nasty. Please download/save combofix to your computer and run it. This is a VERY POWERFUL TOOL...

(IMPORTANT) Click OK to continue on those popup messages from combofix, DO NOT disable the anti-virus, just click OK to go on and you might have 3 different OK boxes to pop up, and if it ask to download the recovery console just click no.



Try to run COMBOFIX and it will take about 5 minutes to complete tops. The Microsoft Level 2 Techs use this and nothing gets past it. This is a FREE scan and it does not install anything on your computer, it runs from the command prompt!


http://www.combofix.org/download.php

1) Save it to your desktop

2) Run It



When it is done, you will get a notepad with the report. If anything was deleted it will show you at the top like this....


(((((((((((((((((( other deletions )))))))))))))))))))

Here is you a guide just in case you want to see what happens.



http://www.bleepingcomputer.com/combofix/how-to-use-combofix

After that, close the notepad, restart your computer, and everything should be back to normal.



BEST OF LUCK!
GOD BLESS!

:)
Customer: replied 7 years ago.

I have run combo fix twice as the problem came back. Neither time did it give me a notepad showing the problems deleted.

 

However, although I have managed to install my game now it will windows will not respond to the patches or exes that I try to install to go with it.

 

I ran stopzilla too and that picked up a lot of things fixed etc everything. I uninstalled Ahead Nero as that seemed to be the problem installing the game with the "not a valid win32 application problem" but cann't understand why other exes wont be recognised.

Expert:  Anthony Brewster replied 7 years ago.
Like i said, you have a nasty rootkit and those can be a headache. Its worse than a virus. Do this. Run ComboFix again but in Safemode with Networkgin.

1) Turn on the computer
2) Keep tapping/pressing F8 until you see advanced options menu
3) Use arrow keys to select safemode with networking and press enter
4) Press enter for os/xp
5) Choose your account (not admin)
6) Click yes to continue in safemode

Now, download/save combofix again and run it,.

:)
Customer: replied 7 years ago.

Hi just read your message, have not been on for the last few days as the computer went down completely.

 

have just reinstalled XP Pro on c: as it was originally on e: due to a hard disk malfunction. After spending the last 5 days trying to fix blue screen problems am now back but have lost my brand new 650Gb hard drive.

 

Cannot believe the problems I'm having. Been into bios not showing there, run rescan through diskpart not showing there. wot the dickens is going on now. Cannot believe a root infection can cause all these problems.

 

regards

 

Naomi

Expert:  Anthony Brewster replied 7 years ago.
Thanks! Yes, there are pretty bad. If it is not showing in the bios it could be the settings have gotten changed somehow. Call your OEM and have them to check your bios settings to make sure its set right.

:)
Customer: replied 7 years ago.
I don't have one. Trying to sort it out myself. Downloaded updated drivers for my other rig hardware. Don't know whether to open her up and check cabling as the hard drive that's missing is a SATA connection. This drive is brand new as the other one burnt out loosing over 300Gb of data
Expert:  Anthony Brewster replied 7 years ago.
wow! Yeah, you might want to open it up to check to make sure its plugged in right.

Related Computer Questions