How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Greg A. Your Own Question

Greg A.
Greg A., Consultant / Engineer
Category: Programming
Satisfied Customers: 8119
Experience:  Working in Computer/Electronics 25+ Years, Storage Interface Expert
5229702
Type Your Programming Question Here...
Greg A. is online now
A new question is answered every 9 seconds

Can anyone explain why the “More” command appears when it is

Customer Question

Can anyone explain why the “More” command appears when it is not invoked. It only happens in Posts that have a video. When one clicks on it it goes back the post and the “More” is gone. You cans see this in our site gowd.us in the category Health Care/Doctors the first post Being Mortal … In our posts the More reads Read More.
If you can tell me how to prevent this it would be much appreciated.
Thanks.
Submitted: 1 year ago.
Category: Programming
Expert:  Greg A. replied 1 year ago.
Hello & Welcome to Just Answer,
Sorry I didn't see your question earlier.
I took a quick look at your site and I believe I saw the "Read Mode" button at the bottom of EVERY post when I used the link you mentioned (which appears to be a "Category Archive" list). Here is the page I'm looking at, using your description above.
http://gowd.us/category/health/doctors-2/
I also noticed that when I hover my mouse over the button, I see a "Permalink to (and the post title)".
I also noticed that the site is using the "NewsScope" theme, and when I looked a bit further, I noticed that this "readmore" button is part of that theme (it is built-in).
So I think if you want to get rid of that button, someone will need to modify files for that theme, or perhaps that theme can be "customized" to not display that button.
As a reference, let me give you a link to a WP support page that mentions a similar issue - with the NewsScope theme. Look at the 3rd post from the bottom for a possible solution (look or search for "readmore-wrap" in your browser).
https://wordpress.org/support/topic/more-5
I hope this helps explain "why" this is appearing on the page(s).
Please let me know if you have any more questions.
And when you are ready, please take a moment to rate my service level (Excellent is my goal) so that I get credit for helping you today.
You should see some "smiley faces" or "stars" to do that, but please let me know if you do NOT see them or can not use them.
Thanks, ***** *****
(im)
Customer: replied 1 year ago.
I don't think you look a the Doctors in Health Care. This first post contains a Video and a "Read More" which was not invoked but disappears when click on and the post reappears. This happens in every post with a video.
Customer: replied 1 year ago.
Sorry. The Read More doesn't appear in the video posts only in the Archived posts with videos.
Customer: replied 1 year ago.
I don't want to get rid of the Read More as I need it in some places. It just has to be setup so it doesn't appear when not invoked which I never do when there is a video in a post.
Expert:  Greg A. replied 1 year ago.
Hi again,
Sorry for any delay - crazy weather/traffic today kept me offline.
May I ask what browser you are using to make or look at your site?
I only ask because I'm using Firefox (latest edition) and DO see those "read more" buttons on EVERY post on the page I linked to above.
I will try to send a screen shot of what I am seeing, but the site here is not letting me insert images right now.
Also, what "templates" are you using to make these posts - BOTH WITH and WITHOUT videos in them?
Thanks
Customer: replied 1 year ago.
IE 11. Probably all the Health Care post have a Read More in them because of their length. I just put a new post in Health Care/Doctors without entering the Read More command. The title is "Test In Health Car..." and when you retrieve it from Recent Articles the Read More doesn't appear. When you get from Health Care/Doctors the Read More is there. So I guess Archives inserts it in all posts.
Expert:  Greg A. replied 1 year ago.
Hi Richard,
I just checked with Chrome (Version 43.0.2357.124 m)& IE (version 11) browsers, and saw the same buttons when using those browsers. I even saw your "test" post.
This is when I use the pull-down menu of Health Care >> Doctors.
Here is the link address again: http://gowd.us/category/health/doctors-2/
I assume you are "logged in" to the site. Have you checked to see what is looks like when you are NOT logged in (as I am NOT logged in).
I will check it on my tablet too - if you want me to (looks like it is supposed to be a responsive theme).
And I agree - when I click using the Recent Articles OR the Read more links - the button no longer appears.
Customer: replied 1 year ago.
I just checked in Firefox and it's the same problem. All posts have Read More in the archives. It is not just those with videos.
Customer: replied 1 year ago.
I suspect that there is something wrong with the Archive code which follows:
<?php
/**
* Template Name: Archives
*/get_template_part('content', 'before');
?>
hook('content_before'); ?>
id="post-">
<?php
if(is_user_logged_in()) {
?><?php
}
?>
<?php
if(has_post_thumbnail()) {
the_post_thumbnail(
array(300, 225),
array("class" => "alignleft featured_image")
);
}
?>
<?php
the_content('');
wp_link_pages( array( 'before' => '' . __( 'Pages:', 'themater' ) . '', 'after' => '' ) );
?>
-->
hook('content_after'); ?>
Expert:  Greg A. replied 1 year ago.
Hi again,
That could very well be.
Whatever module(s) that call the "readmore" class (or readmore-wrap) to build or insert those elements could do it.
When I was looked at the CSS files for the NewsScope theme yesterday, I think I saw the definitions for the "readmore-wrap" in there.
NOTE: I was doing a site once that the final solution to getting rid of a particular object display WAS to use the "{display:none;}" mentioned in the article I referenced above. This was because when I tried to modify the code directly, it messed up other elements of the site - where were expecting that code to be a particular way.
That is the "danger" of using code that comes from someone else ... it hard to discover ALL the dependencies of the files (modules).
Please let me know what you would like to go from here.
Thanks
(im)
Customer: replied 1 year ago.
The problem is that I use Read More quite a bit. So I guess the problem can't be solved.
Expert:  Greg A. replied 1 year ago.
May I ask HOW you are using Read More, or how you INTEND to use it?
Is it for "excerpts" of posts, that are longer than a certain number of characters, so that when the post appears in a LIST (like the archive list) it is suppose to be a few lines of text, and then say "Read More" after that?
Thanks
(im)
Customer: replied 1 year ago.
Just used when the article is too long. Maybe there is some css code we could use to stop the Read More when desired.
Expert:  Greg A. replied 1 year ago.
I think the KEY is to find where the Read Mode code is, and how it is called (or not).
Can you tell me what version of WP you have running there?
I only ask so I can grab the core code and take a look to see if I can find the readmore code. I suspect it is in the core, as I have a 3.7.8 version of WP running on my development system, and the read more link IS on every post in the category lists I pull up - ANY category - and I'm NOT running the NewsScope theme there.
Customer: replied 1 year ago.
4.2.2 I can give you login if that helps.
Expert:  Greg A. replied 1 year ago.
Hi again,
Thanks for the offer, but just want to check the CORE files, and see if I can find the readmore calls.
This may take a little while, so please don't hang online waiting. You should get an email when I post back.
Thanks
Expert:  Greg A. replied 1 year ago.
Hi again,
Sorry for the delay. My "other boss" had me busy ;).
OK - here is what I did:
1) Installed a FRESH version of WP 4.2.2, using default theme (2015).
2) Made some TEST post, with a "Read More Tag" inserted (using the visual post editor), and with the posts in a "TEST" category.
3) Here is the TEXT version of what I see on the screen when I click on the TEST category link (shows all posts in that category - similar to your pull-down menus.
=======================================
Category Archives: Test
TEST
TEST POST 02
VIDEO JUNE 10, 2015
VIDEO FORMAT – Should be VIDEO HERE
This is just a TEST POST – number 02. Let’s see what happens.
Insert Video Here (not done yet).
video
This is just a TEST POST – number 02. Let’s see what happens.
This is just a TEST POST – number 02. Let’s see what happens.
This is just a TEST POST – number 02. Let’s see what happens.
This is just a TEST POST – number 02. Let’s see what happens.
This is just a TEST POST – number 02. Let’s see what happens.
TEST
TEST POST 01
JUNE 10, 2015
STANDARD FORMAT – NO-VIDEO HERE
This is just a TEST POST – number 01. Let’s see what happens.
This is just a TEST POST – number 01. Let’s see what happens.
Continue reading Test Post 01→
=======================================
NOTE the LAST LINE above, which is the result of inserting the TAG in the TEST POST 01 post.
4) Below is the same results, with the NewsScope theme installed and activated.
=======================================
CATEGORY ARCHIVES: TEST
TEST POST 02
JUNE 10, 2015 WP422
VIDEO FORMAT – Should be VIDEO HERE
This is just a TEST POST – number 02. Let’s see what happens.
Insert Video Here (not done yet).
video
This is just a TEST POST – number 02. Let’s see what happens.
This is just a TEST POST – number 02. Let’s see what happens.
This is just a TEST POST – number 02. Let’s see what happens.
This is just a TEST POST – number 02. Let’s see what happens.
This is just a TEST POST – number 02. Let’s see what happens.
Read More
TEST POST 01
JUNE 10, 2015 WP422
STANDARD FORMAT – NO-VIDEO HERE
This is just a TEST POST – number 01. Let’s see what happens.
This is just a TEST POST – number 01. Let’s see what happens.
Read More
=======================================
Notice the "Read More" at the END of EACH post in the list now AND
The fact that the "Continue reading Test Post 01→" is now GONE from TEST POST 01.
So what that tells us is that the THEME is putting these "Read More" BUTTONS - on the end of EACH POST - WHEN the posts are shown AS A LIST.
I have NOT checked every line of code to see what the NewsScope theme is doing to make these changes, but we now KNOW it is the theme that is making these changes.
So if you want to keep using that theme, that is where you should look to find out WHERE the "Continue reading" is being removed and the "Read More" button are being put in there.
NOTE: I am ASSUMING that the "Read more TAG" is what you were referring to when you use the term "read more command".
That could be where the misunderstand is/was between our messages, as "miscommunication" and using the SAME TERMS for DIFFERENT features or functions can often lead to issues like this.
If you can, please try at least temporarily switching to the 2015 theme, and see if you have similar results to what I had.
Also, you may want to try this on some "test site" or offline development tool. I use XAMPP as my development and testing tool - running on one of my Windows machines.
Please let me know what you find or if you have any more questions or clarification for me.
Thanks, ***** *****
(im)
Customer: replied 1 year ago.
Below are parts of emails I receive form the theme provider:On Thu, Jun 11, 2015 at 2:50 PM, ***** *****s wrote:
> So all archived posts have to display Read More?
Response:
Yes,
but it can be removed.
But, it will be removed from all the archived posts.
Expert:  Greg A. replied 1 year ago.
Hi again,
I may have missed some information, but is the theme provider offering to modify the theme for you?
It does sound like we now KNOW it is the theme that is causing this issue.
(im)
Customer: replied 1 year ago.
The only thing they offered regarding archived post is to display Read More in all posts or not to ever display it. I though they could have offered some code that could fix the problem. Have you been able to test archived posts, with Read More invoked and not in another theme?
Expert:  Greg A. replied 1 year ago.
I did NOT test the archived posts - for if the Read More Tag would appear in the original post. I can do that for you, but it will take at least an hour or two, as that is on my development system (at another location).
Let me know if you would like me to do that.
Thanks
(im)
Customer: replied 1 year ago.
Forget. It probably takes a different theme to get rid of the problem.
Expert:  Greg A. replied 1 year ago.
Hi again,
Sorry for any delay in responding.
I believe you are right.
One of the hardest choices to make is picking the right theme - for any site.
I hope I have answered your question of"
"Can anyone explain why the “More” command appears when it is not invoked."
Please let me know if you need any more help.
And when you are ready, please take a moment to rate my service level (Excellent is my goal) so that I get credit for helping you identify this issue.
You should see some "smiley faces" or "stars" to do that, but please let me know if you do NOT see them or can not use them.
Thanks, ***** *****
(im)
Customer: replied 1 year ago.
I guess you have never run into that problem before. If you run across a theme that doesn't have that problem I would like to know about.
Expert:  Greg A. replied 1 year ago.
Hi again,
I have run into "similar" issues, like the one I referenced earlier. That was the one that was resolved by "hiding" the required field (or display button) - using the "display none".
I will certainly keep an eye out for themes that do a better job of doing what you want to see (or not see - as the case may be).
Take Care, Greg A.
P.S. May I ask if you have considered hiring someone to create a "custom theme" for you? I believe there are folks out there that do offer such services.
(im)
Customer: replied 1 year ago.
Thanks.
Expert:  Greg A. replied 1 year ago.
You are quite welcome.
And when you are ready, please take a moment to rate my service level (Excellent is my goal) so that I get credit for helping you with this issue.
You should see some "smiley faces" or "stars" to do that, but please let me know if you do NOT see them or can not use them.
Thanks, ***** *****
(im)
Customer: replied 1 year ago.
I found the answer in case you ever need it, see below:
Actualy,
there is a solution with using the custom field.
Try the below:1. Edit each post you do not want to display the read more button and:
- Add custom field with name: disable_readmore and value true
(You can find the custom fields panel under your post editor box. If
it is not displayed, click on "Screen Options" tab at the top-right
and check the "Custom Fields" checkbox.2. Edit the loop.phpFind the below code:#more-<?php
the_ID(); ?>" title="<?php printf( esc_attr__( 'Permalink to %s',
'themater' ), the_title_attribute( 'echo=0' ) ); ?>"
rel="bookmark">option('read_more'); ?>Replace the above code with below code:
<?php $display_read_more = get_post_meta( get_the_ID(),
'disable_readmore', true );if( empty( $display_read_more ) ) { ?>
<a class="readmore" href="<?php
the_permalink(); ?>#more-" title="<?php printf(
esc_attr__( 'Permalink to %s', 'themater' ), the_title_attribute(
'echo=0' ) ); ?>" rel="bookmark">option('read_more');
?>
Customer: replied 1 year ago.
That replacement code was wrong. In loop.php It should have been:
<?php $display_read_more = get_post_meta( get_the_ID(), 'disable_readmore', true );if( empty( $display_read_more ) ) { ?>
#more-" title="" rel="bookmark">option('read_more');?>
Expert:  Greg A. replied 1 year ago.
Hi again,
Thanks for letting me know what was found.
And don't forget to TEST your solution on ALL pages, posts, etc.
Please let us know if you have any more questions.
And if you think I have been of help, please take a moment to rate my service level (Excellent is my goal) so that I get credit for helping you identify this issue. You should see some "smiley faces" or "stars" to do that, but please let me know if you do NOT see them or can not use them.
Thanks, ***** *****