How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Pete Your Own Question

Pete
Pete, Networking Engineer
Category: Networking
Satisfied Customers: 15764
Experience:  CISCO Certified Networking Engineer
30970729
Type Your Networking Question Here...
Pete is online now
A new question is answered every 9 seconds

Network Setup of Printer MG6620 on XP SP3 keeps failing Does

Customer Question

Network Setup of Printer MG6620 on XP SP3 keeps failing
Does show up on Google Cloud Print, but not as installed printer on XP.
Please help. thanks.
===========================================
Setup Results
===========================================
Model :
Canon MG6600 series
Network Setup of the Printer :
Failed
Name :
Port Name :
CNBJNP_D8492FD95390
Network Setup of the Scanner :
Completed
Name :
Canon MG6600 series(D8.49.2F.D9.53.90)
Network Type :
Infrastructure
SSID :
CleverEagle
===========================================
Submitted: 1 year ago.
Category: Networking
Expert:  Pete replied 1 year ago.

Hi,

The driver on the CD-ROM may be out of date.

Try deleting the printer from your computer, then download the latest XP printer driver from the Canon website:

http://www.usa.canon.com/cusa/support/consumer/printers_multifunction/pixma_mg_series/pixma_mg6620

Customer: replied 1 year ago.
Pete,
Printer not shown on XP computer (lets call XP1), therefore, can't delete. (Wireless printer),
Installed successfully on sister XP computer (lets call XP2) with same Canon CD.
Both XP1 and XP2 are Windows XP Professional SP3.
Both are wired-LAN to Linksys EA9200 which wi fi connected to Canon MG6620.
Can print to MG6620 w/o problem from several systems via Google Cloud print
so WiFi connectivity is fine.
Something unique to XP1 is causing problem.
Can print to other LAN network printers from XP1 without problem
Expert:  Pete replied 1 year ago.

Is this on an office network?

Do you have administrative rights on XP1?

Customer: replied 1 year ago.
Problem NOT FIXED.
Home network.
I am administrator on all systems.
Sorry for delay, I have been occupied with other business.
Please do not close this item until it is resolved.
Thank you.
Expert:  Pete replied 1 year ago.

It's ok, I will not close the question, and you can reply back whenever it suits.

What type of network have you set up at home?