How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Russell H. Your Own Question
Russell H.
Russell H., Computer Repairer
Category: Computer Hardware
Satisfied Customers: 202
Experience:  Working to keep PC-type computers working since 1988.
13568747
Type Your Computer Hardware Question Here...
Russell H. is online now
A new question is answered every 9 seconds

I have a LogiTeck X-540 unit that was playing CD's in my

Customer Question

I have a LogiTeck X-540 unit that was playing CD's in my computer very nice until a week ago. Now it doesn't do any thing... nothing plays. I tried taking the cables out, and plugged them back in exactly the way they were to be plugged in.
Do you have any idea why this happened, and how I might fix it?
Submitted: 1 year ago.
Category: Computer Hardware
Expert:  Martin replied 1 year ago.

Hello, welcome to JustAnswer my name is ***** ***** I'm one of the experts who will be assisting you today.

Sorry to hear you're having trouble with your sound.

The problem may have nothing to do with the actual sound system but your computer. Have you tried plugging headphones directly into the computer?

May I start a remote session so we can work on the problem together from your computer?

Please reply using the box below.

Regards,
Martin

Related Computer Hardware Questions