How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dr. Hamman Your Own Question
Dr. Hamman
Dr. Hamman, Technician
Category: Classic Car
Satisfied Customers: 2436
Experience:  I have 30 years experience repairing, restoring, and customizing cars, and pickup trucks.
9795573
Type Your Classic Car Question Here...
Dr. Hamman is online now
A new question is answered every 9 seconds

My 78 280z has since day one refuses to restart after about

Customer Question

My 78 280z has since day one refuses to restart after about 15 min of running and about 15 min sitting temp gauge shows very hot that wasn't showing when turnr\ed off all injectors replaced along with all fuel system sensors,,,suggestions?
Submitted: 1 year ago.
Category: Classic Car
Expert:  Classic Car Service replied 1 year ago.

Hello. Welcome to Just Answer. Please allow me to assist you. If your temperature gauge is reading hot after 30 minutes, I would suspect you have a faulty thermostat that is sticking closed. There is the possibility that the coolant temperature sensor is bad, the one with one connector on it. (the other temp sensor, the wone with two wires on it is for the fuel injection). This could be part of the problem if it is bad, as it will not be telling the computer the proper coolant temperature. You say you replaced all of the fuel sensors....The no start problem cound be a crack of leak in the tube between the air-flow meter and the intake manifold. ANy leaks in this tube will not allow the car to start.

Related Classic Car Questions