How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Robert Your Own Question
Robert
Robert, ASE Certified Technician
Category: Chrysler
Satisfied Customers: 4346
Experience:  28 years experience, ASE Master Certified, Chrysler Master Certified, Sprinter Van Certified
49095596
Type Your Chrysler Question Here...
Robert is online now
A new question is answered every 9 seconds

Won't start. Light bright red on instrument panel that is

Customer Question

Won't start.
JA: Have you checked the battery, particularly the terminal connections? Are they corroded?
Customer: Light bright red on instrument panel that is not explained in manual.
JA: What is the model/year of your Chrysler?
Customer: Battery is fine.
JA: What year is your Chrysler?
Customer: 2006 300
JA: Are you fixing your 300 yourself? What have you tried so far?
Customer: I am not a mechanic. Tried pulling black fuse. Tried disconnecting battery.
JA: Anything else you want the mechanic to know before I connect you?
Customer: No resistance whatsoever when turning key. Wireless remote on key fob does not do anything.
Submitted: 7 months ago.
Category: Chrysler
Expert:  Robert replied 7 months ago.

Hello, welcome and thanks for asking your question. My name is*****'m a Certified Auto Technician with 29+ years experience. I will do my best to assist you. please keep in mind that I may need to ask questions of you before I can answer. When you reply please feel free to add as much detailed information as possible pertaining to your concern.

Is that Bright Red light just a "Dot" that is lit on the cluster? Is this light on steady or flashing? Do you have a second key that you can try to start the vehicle with?

Keep me posted...

Thank you,

Robert

Customer: replied 7 months ago.
Bright red dot.
Customer: replied 7 months ago.
Below fuel gauge and speedometer
Customer: replied 7 months ago.
Tried 2nd key. No change.
Customer: replied 7 months ago.
BTW...compass, temp readout, odometer, and gear indicator stay lit, even w key out
Customer: replied 7 months ago.
Car worked fine at 6:10pm. Would not start at 6:58pm
Customer: replied 7 months ago.
Red dot is steady. With key in ignition or out of ignition.
Customer: replied 7 months ago.
My mistake. Red light is flashing.
Customer: replied 7 months ago.
BTW...RKE now working.
Expert:  Robert replied 7 months ago.

Sounds like you are having problems with the Immibilizer System. Usually these symptoms lead to the need to replace the SKIM (AKA Sentry Key Immobilizer Module or WCM - Wireless Control Module). This module requires special programming and to reprogram the keys after replacement of the module. For this reason it is HIGHLY recommended to tow it to the dealer for diagnosis and repair. Most likely replacing the SKIM module and programming it will fix the problem...

Keep me posted and let me know if you have any additional questions...

Thank you,

Robert

If you need additional information, don't hesitate to ask. If I have answered your question, Please kindly "Rate" my service, it is greatly appreciated. Thank you and thanks for asking your question!

Robert

Expert:  Robert replied 7 months ago.

Hello,

I just wanted to check in with you to see if you need more help with your concern. A non rated question normally times out within 7 days, so I wanted to stay in contact with you to see if the problem has been solved.

If I have helped you resolve your concern and you have already rated my response, I want to say "Thanks, ***** ***** you know you can still follow up on this concern if needed. Also to let you know you can bookmark >>> My Profile Page <<< in case you have another automotive question in the future. Make sure to begin your question with "Robert R" so I will be able to easily find it

If we are still working on your concern, please post a reply so we can continue.

If you are happy with my answer and have not rated my response, please do so asap to complete the transaction. It is greatly appreciated as I recieve no compensation until you do so...

If you're not satisfied with my answer, BEFORE rating, please post a reply with a short explanation as to why. I may have a better explanation for you... It also helps me to refine my answers to help future customers more thoroughly and efficiently.

Customer: replied 7 months ago.
Robert was correct. I towed the car to the dealership. The paperwork says "replaced WCM". But the part number says "SWITCH IG"
Expert:  Robert replied 7 months ago.

Can you post the part number? I'll check to verify exactly what was replaced...

Thank you,

Robert

Expert:  Robert replied 7 months ago.

Hello,

I just wanted to check in with you to see if you need more help with your concern. A non rated question normally times out within 7 days, so I wanted to stay in contact with you to see if the problem has been solved.

If I have helped you resolve your concern and you have already rated my response, I want to say "Thanks, ***** ***** you know you can still follow up on this concern if needed. Also to let you know you can bookmark >>> My Profile Page <<< in case you have another automotive question in the future. Make sure to begin your question with "Robert R" so I will be able to easily find it

If we are still working on your concern, please post a reply so we can continue.

If you are happy with my answer and have not rated my response, please do so asap to complete the transaction. It is greatly appreciated as I recieve no compensation until you do so...

If you're not satisfied with my answer, BEFORE rating, please post a reply with a short explanation as to why. I may have a better explanation for you... It also helps me to refine my answers to help future customers more thoroughly and efficiently.