How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Don 'Mo Lurch' Your Own Que...
Don 'Mo Lurch'
Don 'Mo Lurch', Aftermarket & Factory Electronics
Category: Chrysler
Satisfied Customers: 516
Experience:  Cert. Chrysler Warnty, Heavy Line Mech, Mobile Electronics. Sales, Installation & Repair for 30 years
1609972
Type Your Chrysler Question Here...
Don 'Mo Lurch' is online now
A new question is answered every 9 seconds

I just finished replacing the transmission in my 2002 Pt

Customer Question

I just finished replacing the transmission in my 2002 Pt Cruiser and now it won't start. I've checked and double checked everything and I don't have any idea what's going on. I'm thinking it is the starter because it won't even crank or click. The battery is brand new and so are the plugs and wires. There is power to all the lights, radio, exc. and the headlights don't dim when I turn the key. What is going on?
JA: I'm good. And you?
Customer: I've been better but I'm good.
JA: Sorry to hear it. How can we be of help?
Customer: Did you get my first message? I explained what was going on in the first message.
JA: Have you checked the fuses? Have you checked the bulbs?
Customer: I've checked all of the fuses and as far as I can tell they are all in working order. The car was running before I replaced the transmission.
JA: Are you fixing your PT Cruiser yourself? What have you tried so far?
Customer: Yes I am fixing my PT Cruiser myself. I have cleaned all connections and just tried turning the key.
JA: Anything else you want the mechanic to know before I connect you?
Customer: Not off of the top of my head no. Thank you.
Submitted: 5 months ago.
Category: Chrysler
Expert:  kalamykid replied 5 months ago.

Are you sure you have the big ground wire from the battery connected and tight? It should bolt to one of the bell bolts.

Customer: replied 5 months ago.

Yes. I cleaned the connection and the bolt to make sure there would be a good connection.

Expert:  kalamykid replied 5 months ago.

And you have double checked the trigger wire on the starter?

Customer: replied 5 months ago.

Yes. All are clean and properly connected.

Expert:  kalamykid replied 5 months ago.

Do you have a digital volt meter?