How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Technician
Category: Chrysler
Satisfied Customers: 27134
Experience:  Over 17 years diagnosing and repairing automobiles various makes and models with some training and certifications.
14928985
Type Your Chrysler Question Here...
Pete is online now
A new question is answered every 9 seconds

I have a 2006 pt cruiser an as im driving it the all the

Customer Question

I have a 2006 pt cruiser an as im driving it the all the gauge lights flash.. the engine stalls an seems to shut off but doesn't.. I don't kno if this is a factor or not but seems to happen when I use the heater more.. but that is jus a guess...
JA: Is the check engine light on? Does the car stall at idle or when driving?
Customer: its not on... the gauge lights jus flash an then engine boggs down..
JA: Are you fixing your PT Cruiser yourself? What have you tried so far?
Customer: so far when the engine light did stay on.. I took it to the local pep boys an they put it on the puter.. it came up with that oxygen sensor needed replacing.. that has been done, but the problem still happens
JA: Anything else you want the mechanic to know before I connect you?
Customer: I have jus had oil change.. an everything done for it to pass Md inspection..
Submitted: 7 months ago.
Category: Chrysler
Expert:  Pete replied 7 months ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

This sounds like a possible fault with a loss of voltage or ground.I have seen loose or corroded or damaged battery cables or connections cause this type of fault here.I would have these checked for any issues.The other component I have seen is a fault with the electronic ignition switch or the instrument cluster itself needing replaced for this fault.I would have these checked into if the cables and connections are found to be o.k. at and leading from the battery and fuse panels.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service,your 5 star rating is appreciated.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete