How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: Chrysler
Satisfied Customers: 22376
Experience:  ASE Master & Advanced level certified, Chrysler Master Certified, Trans and Hybrid Specialist
9825021
Type Your Chrysler Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

Clicking sound coming from relay.. yes 112k, 02 Chrysler

Customer Question

clicking sound coming from relay..
JA: How many miles are on the car? Has the car been starting normally?
Customer: yes 112k
JA: What is the model/year of your Chrysler?
Customer: 02 Chrysler sebring
JA: Are you fixing your Sebring yourself? What have you tried so far?
Customer: yes...replaced motor and hydraulic cylinders.
JA: Anything else you want the mechanic to know before I connect you?
Customer: no how much is it
Submitted: 7 months ago.
Category: Chrysler
Customer: replied 7 months ago.
Motor runs and has extended cylinders but they do not retract. I hear a clicking from the rear relay when I flip the switch the opposite..motor does not kick when switch is flipped the other way. Cylinders are not attached to top since I am troubleshooting. I wanted to make sure they worked both ways before reinstalling. I have checked all fuses and they are good.
Expert:  sprinkles08 replied 7 months ago.

Hello and welcome to JustAnswer!

The problem could be a handful of things. You could have a wiring issue, a bad relay, or the pump itself may have failed. the first thing you'd want to do is check for power and ground at the motor when pressing the switch to see if one or both are missing, or if they're present and the pump has failed. Has any testing been done?

Customer: replied 7 months ago.
I have power to motor. It works. Motor will kick in and cycle when pressing button top down. When pressing top up the motor does nothing. Just a clicking sound from relay.
Expert:  sprinkles08 replied 7 months ago.

You have power and ground to motor when pressing the button to raise the top yet the pump does not run?

Customer: replied 7 months ago.
That is correct. I only hear clicking coming from relay.
Expert:  sprinkles08 replied 7 months ago.

If there is power and ground at the motor but it does not run then it has failed and needs to be replaced.

Customer: replied 7 months ago.
I just replaced the motor. My old one does the exact same thing.
Expert:  sprinkles08 replied 7 months ago.

How are you testing for power and ground?