How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08, ASE Certified Technician
Category: Chrysler
Satisfied Customers: 21432
Experience:  ASE Master & Advanced level certified, Chrysler Master Certified, Trans and Hybrid Specialist
Type Your Chrysler Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

I just had a new battery installed on a 2011 Chrysler 200.

Customer Question

I just had a new battery installed on a 2011 Chrysler 200. Everything works fine except that the EVIC does not display when I press the button on the steering wheel. What could be wrong?
JA: How has the car been driving lately?
Customer: yes
JA: Are you fixing your 300 yourself? What have you tried so far?
Customer: Had the battery installed by a battery dealer. I have not done any work myself.
JA: Anything else you want the mechanic to know before I connect you?
Customer: No
Submitted: 16 days ago.
Category: Chrysler
Expert:  sprinkles08 replied 16 days ago.

Hello and welcome to JustAnswer!

It sounds as if you have an internal issue in the instrument cluster.

I assume the cluster works otherwise?

Does nothing in the vacuum fluorescent display under the gauges work at all?

Are there any warning lights on?

Do other functions from the steering wheel still work such as radio controls, cruise control, etc?

Customer: replied 15 days ago.
Instrument cluster works fine otherwise. No warning lights on. Only thing not working is the display of compass, mpg, tire pressure, etc that results from pressing the menu button.
Expert:  sprinkles08 replied 15 days ago.

If the vacuum fluorescent display doesn't work yet the rest of the cluster does and there are no other issues then that does indicate instrument cluster failure.