How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Don 'Mo Lurch' Your Own Que...
Don 'Mo Lurch'
Don 'Mo Lurch', Aftermarket & Factory Electronics
Category: Chrysler
Satisfied Customers: 504
Experience:  Cert. Chrysler Warnty, Heavy Line Mech, Mobile Electronics. Sales, Installation & Repair for 30 years
Type Your Chrysler Question Here...
Don 'Mo Lurch' is online now
A new question is answered every 9 seconds

Won't start, all lights come on. Even after key removal, A/C

Customer Question

Won't start, all idiot lights come on. Even after key removal, A/C blower, radio, windows etc. work. Remote won't work to lock/unlock. Seems like all electrical power is running even when it should shut off (key removed).
JA: Just to clarify, what are the exact lights you're talking about?
Customer: The full array of lights that come on when you first start, including low oil pressure, low tie pressure, engine fault, etc. - all of them.
JA: What is the model/year of your Chrysler?
Customer: 2007 Pacifica Limited
JA: Are you fixing your Pacifica yourself? What have you tried so far?
Customer: I can't fix anything, just trying to troubleshoot.
JA: Anything else you want the mechanic to know before I connect you?
Customer: No
Submitted: 24 days ago.
Category: Chrysler
Customer: replied 23 days ago.
Now, 24 hours later, the car is totally dead, with not a single light or indication, I guess the battery now having completely drained.
Expert:  Chris (aka - Moose) replied 22 days ago.

Welcome, I'm Chris (aka Moose) I prefer to work when others don't, I am here around lunch and after dinner till after midnight.

  • Sorry no one has helped yet.
  • This is not an answer to your question, just an inquiry if your still needing/wanting help. Because I believe I can help.
Customer: replied 22 days ago.
2007 Pacifica dead as a door nail in my driveway. As stated previously, car would not start and all electrical components remained running after ignition key was removed. Now there's no electrical power at all (presumably having drained the battery).Ed
Expert:  Chris (aka - Moose) replied 22 days ago.

Do you own a volt meter so we can diagnose this?

Have you tried a battery charge or jumpstart?

What si the voltage on the battery posts and battery cables?

Customer: replied 22 days ago.
No, I don't have a volt meter. However, at the beginning of this problem there was no indication of a battery problem. It did nothing when I turned the key except show all the idiot lights; there was plenty of juice, however, to run the lights, radio, windows, etc. The battery kept supplying things with power even after the ignition key was removed, including things that were to be powered only when the engine was running (outlet plug for GPS) or in the ON position.It now is dead. There is now absolutely nothing when I insert and turn the key. I can try jump starting it tomorrow and perhaps borrow a volt meter.
Expert:  Chris (aka - Moose) replied 22 days ago.

We will need a meter to diagnose these electrical issues.

Customer: replied 21 days ago.
Expert:  Chris (aka - Moose) replied 21 days ago.

Let me know when you have the tools needed.

Customer: replied 21 days ago.
I got the volt meter this afternoon, have run out of daylight to jump charge battery and check voltages - will do so tomorrow and reply. It's good that I have another car.
Expert:  Chris (aka - Moose) replied 21 days ago.

Reply when ready

Customer: replied 19 days ago.
After jumper charging the battery, if I used the voltage meter correctly, the reading was 13.
Expert:  Chris (aka - Moose) replied 19 days ago.

While running what is the battery voltage?

Customer: replied 19 days ago.
34;While running"? The vehicle does NOT start, so there's no running. As originally stated, all indicators light up, but no crank, no nothing. Electrical components operate even when ignition key is removed. I'd guess that the ignition switch or TIPM is defective, but I'm not even an amateur.
Expert:  Chris (aka - Moose) replied 19 days ago.

I need to opt out, I do not feel like we are going to be able to get this resolved prior to the post timing out tomorrow. Hopefully another can help.

Customer: replied 19 days ago.
I have scheduled a tow for tomorrow to take it for diagnosis and repair.

Related Chrysler Questions