How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Technician
Category: Chrysler
Satisfied Customers: 24682
Experience:  Over 17 years diagnosing and repairing automobiles various makes and models with some training and certifications.
14928985
Type Your Chrysler Question Here...
Pete is online now
A new question is answered every 9 seconds

Problem with radiator fan speed being low when sitting

Customer Question

problem with radiator fan speed being low when sitting idling after gets hot. Fan comes on normally for awhile, but when gets hot in engine compartment, fan will not activate to high speed as needed. Then It will run slowly, but will speed up when push connector toward radiator. (2010 chrysler T&C). I replaced high speed fan relay. When relay initially starts clicking, no voltage is going to fan motor connector. When fan does start, it is low speed and then speeds up when connector is pressed sideways. It reads 13.45 volts when disconnected and tested when fan is running. Is there second relay, or a bad connection in motor , or was my replacement relay defective? EM
JA: How many miles are on the car? Has the car been starting normally?
Customer: 129,000 but fan replaced in 2013 after collision with a deer.
JA: What is the model of your '10 Chrysler?
Customer: Town and country 3.8 V6
JA: Are you fixing your Town and Country yourself? What have you tried so far?
Customer: replaced the fan relayand still same proplem. temp gage worling properly. and tested the voltage, ran fan motor on direct 12 current=OK
JA: Anything else you want the mechanic to know before I connect you?
Customer: just the info I sent with orig question.
Submitted: 2 months ago.
Category: Chrysler
Expert:  Pete replied 2 months ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

If you are able to press on the connector and the fan speed changes this usually indicates that the fault is in the connector or connection itself with it being loose,damaged or corroded needing repaired or replaced.I would inspect the connector/connection for any issues and if any issues are found they will need repaired to correct this fault here.If this is or was checked and found o.k. let me know.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service,your 5 star rating is appreciated.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Related Chrysler Questions