How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Don 'Mo Lurch' Your Own Que...
Don 'Mo Lurch'
Don 'Mo Lurch', Aftermarket & Factory Electronics
Category: Chrysler
Satisfied Customers: 510
Experience:  Cert. Chrysler Warnty, Heavy Line Mech, Mobile Electronics. Sales, Installation & Repair for 30 years
1609972
Type Your Chrysler Question Here...
Don 'Mo Lurch' is online now
A new question is answered every 9 seconds

Fan not coming on and its overheating, coolant is fine

Customer Question

Fan not coming on and its overheating
JA: Have you checked the coolant? Have you checked for a leak in the cooling system?
Customer: coolant is fine radiator fan dont come on
JA: What is the model/year of your Chrysler?
Customer: 2008 pt cruiser mexico made base L4
JA: Are you fixing your PT Cruiser yourself? What have you tried so far?
Customer: thinking its maybe one or both the relays on the radiator but also shows two in PDC and one in fuse box
JA: Anything else you want the mechanic to know before I connect you?
Customer: thinking its electrical
Submitted: 2 months ago.
Category: Chrysler
Expert:  david craig replied 2 months ago.

Hi Im David, allow me to look up some info for your vehicle. thank you

Customer: replied 2 months ago.
k waiting no hurry
Expert:  david craig replied 2 months ago.

it wont be the relay. both of them dont go bad together, you are going to have a bad fan control module.

Customer: replied 2 months ago.
where is the fan control module
Customer: replied 2 months ago.
could the thermostat cause this at all also?
Expert:  david craig replied 2 months ago.

well i am calling the module a relay set. usually when a relay goes bad its in the power distribution box, but on your model there is a relay set to the left of the fans

Customer: replied 2 months ago.
2 of them
Expert:  david craig replied 2 months ago.

ig the car was oveheating only, and the fans were coming on, i would say the thermostat could cause it, but thats not whats happening here.

Customer: replied 2 months ago.
thanks confirmed what i was thinking but friend said have you checked the thermostat with all the crap in these cars since they electronic controlled them cant be sure of anything
Expert:  david craig replied 2 months ago.

Here is the wiring diagram, assuming you have the 2.4L non-turbo:

Check both of those fuses. The 'fuse block' is in the dash. The 'power distribution center' is under the hood.

The diagram shows which relay pins should have power at all times, and which ones have power with the key on. It also shows how the powertrain control module controls both relays.

Do you understand this wiring diagram?

Customer: replied 2 months ago.
I do i have an electronic background so yes i understand this diagram its easy just wasn't sure it was a 2008 when i saw it earlier and there seem to be a few out there on pt's and they arent all the same and yes mine is non turbo
Customer: replied 2 months ago.
also since it just had a boat ride and probably the relays got corroded in those shipping containers is my guess
Expert:  david craig replied 2 months ago.

ok. pretty much just jump 12vdc to the fans to verify their operation. if they work, then try the relays.

Customer: replied 2 months ago.
question # 2 motor mounts just had 2 replaced in the left side of the motor I need to get the transmission mount and the rear one replaced my transmission is the automatic version and there seems to be a few on the sites ive seen for these two mounts can you help steer me in right direction since I wont be replacing these myself but want to get the parts
Customer: replied 2 months ago.
Thanks for the fan answers also
Expert:  david craig replied 2 months ago.

you already replace the mounts on the passenger side?

Customer: replied 2 months ago.
top and bottom one
Customer: replied 2 months ago.
should of specified left as your looking at engine from front not from drivers seat sorry.
Expert:  david craig replied 2 months ago.

ok. ill send you something on the others

Customer: replied 2 months ago.
Thanks much
Expert:  david craig replied 2 months ago.

thanks for your patience i got busy here at my shop

Expert:  david craig replied 2 months ago.

heres some drawings.

Expert:  david craig replied 2 months ago.

i think they are the same ones youve replaced already?

Customer: replied 2 months ago.
5 and 10 on first 2 diagrams is what has been replaced need the granny one and the 3rd engine mount think it's rear of engine compartment not sure if your say pic is showing it or not
Customer: replied 2 months ago.
Tranny even
Expert:  david craig replied 2 months ago.

oh you thats the bugger. let me find the instructions

Expert:  david craig replied 2 months ago.

the best i can tell you is go to you tube for the tranny mount replacement. i have no info on the replacement. i have done quite a few, but its a matter of getting in there and doing it. as far as the original question about the fans not coming on, is that resolved?

Expert:  david craig replied 2 months ago.

checking in to see how its going

Customer: replied 2 months ago.
the fan is not resolved but mainly cause ive had other things come up and its been moved down priority list also need to find a tool to remove the relay as my chanel locks wont give me enough bite on the relay w/o crushing it to seperate it from the holder. olus no play in the wiring at all to pull it up some to make it easier gonna try to tackle again this weekend
Customer: replied 2 months ago.
olus was suppose to be plus
Expert:  david craig replied 2 months ago.

ok