How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: Chrysler
Satisfied Customers: 22117
Experience:  ASE Master & Advanced level certified, Chrysler Master Certified, Trans and Hybrid Specialist
9825021
Type Your Chrysler Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

Replaced both sending units twice in 06 Pacifica works 2

Customer Question

Replaced both sending units twice in 06 Pacifica works 2 weeks then fills slow and drop to empty after 1/2 tank
Submitted: 6 months ago.
Category: Chrysler
Expert:  sprinkles08 replied 6 months ago.

Hello and welcome to JustAnswer!

This is happening because there is no fuel transfer. As the engine runs the primary fuel pump sends pressurized fuel to the secondary pump. Bleed pressure from the regulator runs through a venturi to push fuel through it, it picks up fuel from that side of the tank and sends it back to the other. What's happening is fuel is not transferring.

This could be due to a bad secondary pump but is most likely the primary. Low pressure from the primary is usually what I see causing lack of transfer.

Customer: replied 6 months ago.
But it fills slow to and I replaced them twice. Does the plastic fuel tank break down and plug the secondary side and cause no venting
Expert:  sprinkles08 replied 6 months ago.

It fills slowly because the right side of the tank is full of fuel and that's where the rollover valve is. Fuel isn't transferring from the right side to the left while running.

You said you replaced fuel sending units, not pump modules. If you're unsure what was replaced please provide part numbers.

Customer: replied 6 months ago.
No the rollover valve is on the drivers where you fill and the primary pump is on the drivers side with the pump is and I replaced both modules twice
Expert:  sprinkles08 replied 6 months ago.

The rollover valve is in the right side of the tank. The primary pump is on the left, jet pump on the right. It's hard to fuel when there is no transfer because the right side of the tank is filled with fuel covering the rollover valve so vapor can't escape.

Please provide the part numbers of the parts installed.

Customer: replied 6 months ago.
I don't have the part number but they are Delpi modules they work good for 6 months so than I warranty both worked good for 3 weeks and fills slow and and at 1/2 tank goes to empty
Expert:  sprinkles08 replied 6 months ago.

I wouldn't consider an aftermarket pump module except in an emergency.

The problem is either with the primary module not creating enough pressure to open the regulator, or the problem is with the regulator in the secondary module. The tank is going to need to come back out and some pressure testing done to determine which is the case, or the pumps can be replaced together again if the parts store will give you another set. The problem is either with bad replacement parts or the tank is dirty and causing repeat failures. When the pumps were initially replaced the tank should have been completely drained, thoroughly cleaned and wiped dry.