How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dan Your Own Question
Dan
Dan, ASE Certified Technician
Category: Chrysler
Satisfied Customers: 1406
Experience:  Dealer Auto Technician
94707146
Type Your Chrysler Question Here...
Dan is online now
A new question is answered every 9 seconds

I have a 1999 Chrysler 300M..I was just leaving this morning

Customer Question

I have a 1999 Chrysler 300M..I was just leaving this morning and the whole cars electrical shut off..it was like someone unplugged it..I had to drift to the side of the road..is it a fuse??
Submitted: 3 months ago.
Category: Chrysler
Customer: replied 3 months ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  Dan replied 3 months ago.

Hello my name is***** am an ASE Master Technician and I am glad to help you out with your question.

Expert:  Dan replied 3 months ago.

I would look at the battery cables, battery ground, make sure they are clean and tight. Check the power cable that leads from the battery to the main fuse box.

Also, check the main fuse and see if it is blown. It is in the main fuse box under the hood.

Expert:  Dan replied 3 months ago.

Please reply to this if you need more help and we can continue this conversation. If you are satisfied with my service, please rate at the top of the screen. Rating does not close out your question. Remember, sometimes it is difficult to completely diagnose your vehicle without being there, but I will try to give you the best answer I can. If I am not giving you 5 star service, please let me know what I missed.

Thanks,

Dan

ASE Master Technician

Customer: replied 3 months ago.
Hello Dan, we cleaned the battery cables checked the wire to the fuses..and nothing is blown..I think my battery is dead and I need a new one..but the car was working and driving fine and we took it out of the garage and pulled it in front of my house and kept it running..I got in it and put it in drive, pressed on the gas and she took off about 10 feet and everything shut down! No electrical nothing..
Expert:  Dan replied 3 months ago.

You could have a bad alternator, this would cause your battery to go dead and not charge the battery. I would replace the battery and the alternator.

Expert:  Dan replied 3 months ago.

Hello again Dan here,

I am contacting you because the post has not been closed or rated.

This question is coming up on 7 days which means it will time out and close.

You have already paid to get this question answered, but you have not rated.

Let me help some more. Is there anything else I can help you with?

If I did not give you 5 star service, please let me know what I missed.

I do not get compensated for my time and resources unless you rate me.

Thanks

Related Chrysler Questions