How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask david craig Your Own Question
david craig
david craig, Auto Mechanic
Category: Chrysler
Satisfied Customers: 1923
Experience:  owner/mechanic at 3D Automotive
4993992
Type Your Chrysler Question Here...
david craig is online now
A new question is answered every 9 seconds

2007 PT running hot. Yes and have seen no leaking. Coolant

Customer Question

2007 PT running hot.
JA: Have you checked the coolant? Have you noticed any leaking?
Customer: Yes and have seen no leaking. Coolant in radiator looks clean and not discolored. It flows back to the overflow tank and is boiling.
JA: What is the model of your '07 Chrysler?
Customer: PT Cruiser
JA: Are you fixing your PT Cruiser yourself? What have you tried so far?
Customer: Would like to if simple. I have no clue where to start.
JA: Anything else you want the mechanic to know before I connect you?
Customer: no mam
Submitted: 7 months ago.
Category: Chrysler
Expert:  david craig replied 7 months ago.

Hi Im David and thank you for visiting the site, it could be a few things. The first thing that I recommend is something as simple as replacing the radiator cap. Caps that lose their ability to seal in the 16 psi can wreak havoc and is often missed in troubleshooting a coolant system issue It could also be the thermostat. Replacing it is a simple task if you have a basic set of tools.
You could also have a clogged radiator. OR, worst case, you could have a head gasket leak. This could be pushing air into your coolant system and actually pushing it out of your radiator overflow. Lets try the cap first, if its not that then we will go from there, but we wont be throwing parts at your vehicle, there are tests we can do instead. thank you

Customer: replied 7 months ago.
I will get a new cap today and try that. How do I get back in touch with you sense it might be a few days?
Expert:  david craig replied 7 months ago.

I will leave this open, and you can get in touch with me here.

Customer: replied 7 months ago.
Thanks
Expert:  david craig replied 7 months ago.

sure

Expert:  david craig replied 7 months ago.

any progress?

Customer: replied 7 months ago.
Sorry, been working 16 hours a day. Will try asap.
Expert:  david craig replied 7 months ago.

sounds like my long days..wow....

Expert:  david craig replied 7 months ago.

any progress?

Expert:  david craig replied 7 months ago.

any updates?

Customer: replied 7 months ago.
New cap did not fix it. The cooling fan never runs.
Customer: replied 7 months ago.
50 amp fuse in fuse block under the hood is good.
Customer: replied 7 months ago.
Top radiator hose does not seem to get hot.
Expert:  david craig replied 7 months ago.

ok. good. when the top hose doesnt get hot that means the thermostat isnt working

Customer: replied 7 months ago.
Ok, thermostat changed. Jose getting hot now but cooling still not coming on.
Expert:  david craig replied 7 months ago.

cooling fan?

Expert:  david craig replied 7 months ago.

you try try putting a jumper in the cooling fan relay base to see if that turns it on.

Expert:  david craig replied 7 months ago.

heres a print

Expert:  david craig replied 7 months ago.

The Pulse Width Modulated (PWM) cooling fan relay is located below the right headlamp behind the bumper fascia.

Customer: replied 6 months ago.
OK, Fan taken out and tested. One relay bad and one good. Replaced bad relay. What sends a signal to the relays to come on?
Expert:  david craig replied 6 months ago.

ill have that info for you in a moment.

Expert:  david craig replied 6 months ago.

theres a 50 amp fuse in the tipm that supplies power to cooling fan module which controls the relays.

Customer: replied 6 months ago.
I do know that there is 12volts coming in to the bottom fan assy connection and that the fan does run when hooked directly to 12volts.
Customer: replied 6 months ago.
Where is this fuse located?
Expert:  david craig replied 6 months ago.

in the tipm

Expert:  david craig replied 6 months ago.

in the engine compartment

Customer: replied 6 months ago.
In the fuse box under the hood with all the other fuses?