How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tim's Auto Repair Your Own Question
Tim's Auto Repair
Tim's Auto Repair, Mechanic
Category: Chrysler
Satisfied Customers: 15486
Experience:  Have owned a repair shop for 25 yrs.
14541291
Type Your Chrysler Question Here...
Tim's Auto Repair is online now
A new question is answered every 9 seconds

I have a 2003 pt cruiser limited 2.4 non turbo replaced

Customer Question

I have a 2003 pt cruiser limited 2.4 non turbo replaced coli plugs wires upper intake gaskets tbi gaskets and all have been properly torqued. I still intermittingly get p2302 and will run rough and code ignition coil and it is not obviously. where do I go now with a defifinite answer car has only 65,000 miles and otherwise runs well.
Submitted: 3 months ago.
Category: Chrysler
Expert:  Tim's Auto Repair replied 3 months ago.

Hi, My name is ***** ***** for the delay.

I will do my best to assist you.

you have already replaced the coil pack?

Customer: replied 3 months ago.
as well as plugs and wires
Expert:  Tim's Auto Repair replied 3 months ago.

did the new coil help any at all?

Customer: replied 3 months ago.
same problem comes back after 45 min of run time
Expert:  Tim's Auto Repair replied 3 months ago.

do you feel a miss fire?

Customer: replied 3 months ago.
it will miss if you continue to run the engine
if u clear code it will run fine a little while longer and mess up again
Expert:  Tim's Auto Repair replied 3 months ago.

ok..

does it always run well cold?

Customer: replied 3 months ago.
usually but ran well at normal temp yesterday. for about 45 min after fixed yet again
Expert:  Tim's Auto Repair replied 3 months ago.

ok.

first,,check the wire harness that plugs up to the coil pack,,clean the connector with electronics parts cleaner

Customer: replied 3 months ago.
connector is fine
Expert:  Tim's Auto Repair replied 3 months ago.

but,,you problem may be the crank sensor,,

the crank sensor can break down with heat when they go bad and most times not give a code for it

Customer: replied 3 months ago.
my research on line shows many others with same problem has changed there crank and cam sensors and still it exists these are all answers I have found on line for free with all do respect
Expert:  Tim's Auto Repair replied 3 months ago.

there isnt anything left other than the pcm[computer] itself

Customer: replied 3 months ago.
probably thanks for you time much appreciated
Expert:  Tim's Auto Repair replied 3 months ago.

PLEASE COPY AND PASTE the link below to your browser, I have uploaded more info on this there please copy and paste the link below to your main browser[INTERNET EXPLORER or FIREFOX]

.

https://www.dropbox.com/s/fq4dy0u2zjjx23n/0814-pt-2.doc?dl=0

.

if the link doesn’t work that way, try it this way

thanks

.

www.dropbox.com/s/fq4dy0u2zjjx23n/0814-pt-2.doc?dl=0

.

If you are satisfied with my answer, Please Rate my answer by clicking the rating button so I can get credit for my work. I’m not always going to be giving you good news, so please don't let this stand in the way of you accepting my answer. .it does not cost you more money and we will still be able to communicate, ,.please understand, i can not see, hear or touch the vehicle and only know what you tell me. Bonuses and positive feedback are appreciated.. if you are not satisfied with my answer, please do not leave bad feed back ,i will gladly opt out and let another expert handle the question. .if i have sent any diagrams, please print them. .sometimes you may need to right click the image [,then save picture as]to save it to your computer so you can open it with your picture program...Please ask if you need more help

Related Chrysler Questions