How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris Your Own Question
Chris, Technician
Category: Chrysler
Satisfied Customers: 12605
Experience:  30 years certified Chrysler technician, smog license Certified Master Technician
Type Your Chrysler Question Here...
Chris is online now
A new question is answered every 9 seconds

My radio is not getting power, Yes, 300/2010, Yea. I

Customer Question

My radio is not getting power
JA: Have you checked the fuses?
Customer: Yes
JA: What is the model/year of your Chrysler?
Customer: 300/2010
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: Yea. I replaced the fuse
JA: Anything else you think the mechanic should know?
Customer: My subwoofer is also not getting power
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Chrysler Mechanic about your situation and then connect you two.
Submitted: 3 months ago.
Category: Chrysler
Expert:  Chris replied 3 months ago.

Hello, and welcome to just answer. Your TIPM (Totally Integrated Power Module) may have failed. Try this first: Disconnect the negative battery cable for about 2 minutes and then reconnect it. That may reset the TIPM. Let me know if that works.


Expert:  Chris replied 3 months ago.

Hello, just checking back to see how it is going with the 300.


Related Chrysler Questions