How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Don 'Mo Lurch' Your Own Que...
Don 'Mo Lurch'
Don 'Mo Lurch', Aftermarket & Factory Electronics
Category: Chrysler
Satisfied Customers: 518
Experience:  Cert. Chrysler Warnty, Heavy Line Mech, Mobile Electronics. Sales, Installation & Repair for 30 years
1609972
Type Your Chrysler Question Here...
Don 'Mo Lurch' is online now
A new question is answered every 9 seconds

Is this inquiry fee? 87 conquest tsi, 1987, pumped out old

Customer Question

is this inquiry for a fee?
JA: What is the model/year of your Mitsubishi?
Customer: 87 conquest tsi
JA: What year is your Conquest?
Customer: 1987
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: pumped out old fuel, put 6 gall0n of 93 octane back in, car started, ran fine without load. saw volt meter at 17.5v, verified with external meter. shut it down immediately. rebuilt original alternator (new bearings, reg, diode stack, cleaned. tested good by alternator shop). added more shell 93 octane, started fine and ran well without load. after warm up, road tested, good positive turbo boost. few minutes later started running rough and stalled. could wait 1-2 minutes (let fan run) and would start. ran rough, but managed to return to my garage. now starts when cold (assume during rich fuel mixture) and runs without load. when loading (driving) it will again run rough at both idle and above.
JA: How many miles are on the car? Have you checked the spark plugs?
Customer: 75,000, original owner, always performed, engine always had mobil 1 and filter changed before expired interval
JA: Anything else you think the mechanic should know?
Customer: battery new, did find below car what appears as in in line vacuum coupler, very small with one side larger than the other.
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Mitsubishi Mechanic about your situation and then connect you two.
Submitted: 11 months ago.
Category: Chrysler
Customer: replied 11 months ago.
no additional edit
Expert:  Wayne Crawford replied 11 months ago.

Hello. My name is ***** ***** I will be helping you today.

What was the original issue?

Customer: replied 11 months ago.
Poor engine run and idle after warmup. I'm thinking injectors. The '87 Conquest used a two injector throttle body design that I assume uses a primary and secondary (idle and run) approach. I'm having doubts about this design and wonder about putting any more time into it. After just touching the idle injector electrical connector, the car will start, but not idle, then stall. I then used the following procedure: Sprayed starter fluid in air cleaner cavity. It started and allowed me to increase the rpm and the engine ran well. Kept it at around 1500rpm until normal temp and continued to run for several more minutes. Rpm could be increased smoothly. After warmup, rough running at higher rpms. Very slowly eased off throttle and it stalled near idle (950rpm normal) at around 1100rpm. As of now, it will crank and fire (no starter fluid), but not idle or run (engine cooled down to near ambience). I like the G54B engine and the car is quite the little beast for a 2.5L turbo. What do you think?
Expert:  Wayne Crawford replied 11 months ago.

Im really busy right now. Im gonna opt out and see if someone else has anything to offer you. Someone else should be along shortly.