How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Don 'Mo Lurch' Your Own Que...
Don 'Mo Lurch'
Don 'Mo Lurch', Aftermarket & Factory Electronics
Category: Chrysler
Satisfied Customers: 513
Experience:  Cert. Chrysler Warnty, Heavy Line Mech, Mobile Electronics. Sales, Installation & Repair for 30 years
1609972
Type Your Chrysler Question Here...
Don 'Mo Lurch' is online now
A new question is answered every 9 seconds

2003 Chrysler Town & Country LSI AWD. In jump starting the

Customer Question

2003 Chrysler Town & Country LSI AWD. In jump starting the car the polls were hooked up wrong. Frying the battery and both computers. Replaced the main comp. and car started and runs but all the guages are not working. Replaced the next compt. and still does not work. Can you point me in the right direction, besided the junk yard.
Submitted: 8 months ago.
Category: Chrysler
Expert:  CHRIS ZAPANTIS replied 8 months ago.
Hello Im Chris and i can assist you
Expert:  CHRIS ZAPANTIS replied 8 months ago.
You Have checked all of your fuses right?
Expert:  CHRIS ZAPANTIS replied 8 months ago.
What I want you to do is take off the positive and negative cables from your battery and touch them together for 20 second. After you are dont reconnect and see if your guages are working.
Customer: replied 8 months ago.
Chris, we tried your recommindation and it did not work.
Expert:  CHRIS ZAPANTIS replied 8 months ago.
Ive run into cluster problems after changing a battery. Any way you can run a scan on all the modules in the car do you have a capable scanner?