How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08, ASE Certified Technician
Category: Chrysler
Satisfied Customers: 21436
Experience:  ASE Master & Advanced level certified, Chrysler Master Certified, Trans and Hybrid Specialist
Type Your Chrysler Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

Chrysler Sebring: I have a 2004 Chrysler Sebring 2.4L V4. I

Customer Question

I have a 2004 Chrysler Sebring 2.4L V4. I have a crank no start issue that started after one morning my battery went completely dead and wouldn't jump start. I knew it was my battery because I would always have to jump start it so I got new one. When I purchase my new battery the car started immediately but wouldn't accelerate so I parked it and turned it off. Then it start again then I turned it off just make sure it was still starting. Then later I came back to try a third time and it wouldn't start at all till this day. Ovet some time my battery died and not ot was brand new so I thought maybe it was mu alternator so I replaced my alternator and still a crank no start but the crank no start os weak as if there is not enough power to start up and my windows roll up and down really slow and my brand new battery will die if I leave hooked up to the terminals.diedday.datDurin
Submitted: 5 months ago.
Category: Chrysler
Expert:  sprinkles08 replied 5 months ago.
Hello and welcome to JustAnswer!It sounds like you have a couple different issues going on. If the battery is dying while the car sits then you have a component drawing current when the car is at rest. This may or may not be related to the no start condition, although if it's cranking that slowly then it could prevent the engine from starting.Have you checked for fault codes?Have you done an ignition off draw test?

Related Chrysler Questions