How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt, Engineer
Category: Chrysler
Satisfied Customers: 20357
Experience:  Honors degree in Mechanical Engineering, worked 8 years as a Formula 1 engine engineer.
Type Your Chrysler Question Here...
Matt is online now
A new question is answered every 9 seconds

My car start teally well. But when the temprature gauge goes

Customer Question

My car start teally well. But when the temprature gauge goes above the half mark it wount start .i have to wait for the car cool down close to 1/4. When i took off the thermostat it worked better.with new thrmo i have the problem
Submitted: 7 months ago.
Category: Chrysler
Expert:  Matt replied 7 months ago.


its possible that you have 1 or more injectors dribbling fuel ? So its running a bit rich all the time and as a consequence can't cope with a hot start?

if the engine doesn't cut out when hot then I'd say to try a bottle of injector cleaner in the tank and possibly a new fuel filter as the next step

now if it does cut out when hot then this could be a wiring issue as things tend to expand when hot and its possible a poor or partial electrical connection is being pushed apart on one of the major sensors so check the connection plug and wiring to the following;

Airflow meter

Crank position sensor

Cam position sensor

O2 sensor

Throttle position sensor

Also worth checking the connections to the fuel pump for the same reason - unplug each in turn and give them a good squirt of switch / contact cleaner - Not WD40

and also unplug and inspect the main power relays and fuses for signs of overheating or corroded terminals - so the ones for the ECU and the fuel pump

And also unplug the wiring loom connections in the engine bay one at time and inspect for corroded or recessed pins.

Check the resistance of the spark plug leads ( 13-15Kohm / metre) and replace if any doubt or high resistance - Also replace the spark plugs if any of them fail this checklist:

Also its worth checking that the electric pump that feeds the injectors is working correctly, it should run for a few seconds then switch off when you first turn the ignition on. If the connections to this are corroded or damaged then the pump could stop at any time. Check that its relay switches in and out and the relay contacts are clean and bright – replace the relay if in any doubt and do the same for the fuse, ideally measure the voltage at the pump and check its getting 12V

Expert:  Matt replied 6 months ago.


do you still need help?

Bear in mind that the site takes a deposit from you at the beginning and this is held by the site until you rate my answer at which point the cash is split between the site and the expert. I am only paid for my work on this question if you rate my answer, using the star system at the top of the screen. Please do not forget! Thank you

Related Chrysler Questions