How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Don 'Mo Lurch' Your Own Que...
Don 'Mo Lurch'
Don 'Mo Lurch', Aftermarket & Factory Electronics
Category: Chrysler
Satisfied Customers: 511
Experience:  Cert. Chrysler Warnty, Heavy Line Mech, Mobile Electronics. Sales, Installation & Repair for 30 years
1609972
Type Your Chrysler Question Here...
Don 'Mo Lurch' is online now
A new question is answered every 9 seconds

Replaced 02s sensor on 2005 pasifica now she says engine

Customer Question

replaced 02s sensor on 2005 pasifica now she says engine revvs up when starting and runs rough
Submitted: 10 months ago.
Category: Chrysler
Expert:  john -aka eauto replied 10 months ago.

is the engine light still on?

Customer: replied 10 months ago.
Customer: replied 10 months ago.
Car ran fine before changing sensor
Expert:  john -aka eauto replied 10 months ago.

was anything removed to access the sensors?

Customer: replied 10 months ago.
No it was simply to replace
Expert:  john -aka eauto replied 10 months ago.

did you use direct fit or universal sensors? is the engine light currently on?

Customer: replied 10 months ago.
It was just like the one I took out yes light is still on my first answer
Expert:  john -aka eauto replied 10 months ago.

what is the diagnostic trouble code can you tell me the code #s

Customer: replied 10 months ago.
P0038
Expert:  john -aka eauto replied 10 months ago.

and did you change the left or the right upstream?

Customer: replied 10 months ago.
I changed the one closest to engine not the one back by muffler
Expert:  john -aka eauto replied 10 months ago.

driver side or passenger side

there are 2 upper ones

Customer: replied 10 months ago.
Pass side
Expert:  john -aka eauto replied 10 months ago.

ok do you have a scan tool or did the auto parts store scan it for you?

Customer: replied 10 months ago.
No
Expert:  john -aka eauto replied 10 months ago.

and you double checked that you did not interfere with anything else? will it make it to the parts store to scan it again?

Customer: replied 10 months ago.
sorry had to leave go get car what is the scan tool for
Expert:  john -aka eauto replied 10 months ago.

to see if any other codes are present..if its running that bad there should be a code

Customer: replied 10 months ago.
Alright have too take to parts store
Expert:  john -aka eauto replied 10 months ago.

let me know

Customer: replied 10 months ago.
Ok will thanks
Expert:  john -aka eauto replied 10 months ago.

great