How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: Chrysler
Satisfied Customers: 21586
Experience:  ASE Master & Advanced level certified, Chrysler Master Certified, Trans and Hybrid Specialist
9825021
Type Your Chrysler Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

I have just rebuilt a 5.7 in a 2006 300c. New lifters,

Customer Question

Hi,
I have just rebuilt a 5.7 in a 2006 300c.
New lifters, pistons, rebuilt heads, rod and mains, ect..
I have a haunting random multiple misfire and bank 2 knock sensor circuit.
I only have a code reader (small pocket reader).
Very rough idle when cold
Lack of power
Surge when accelerating.
Submitted: 11 months ago.
Category: Chrysler
Expert:  sprinkles08 replied 11 months ago.

Hello and welcome to JustAnswer!

There are quite a few things that can cause a rough idle. It may be as simple as an inaccurate oxygen sensor but it could be an ignition system problem, vacuum leak, the EGR valve hanging open, possibly injector issues or a localized vacuum leak, or it could be cylinder sealing issues. Having this after such extensive work leaves many possibilities.

What was the issue that the engine work was done for?

Was it running correctly before the work was done?

Customer: replied 11 months ago.
The engine ran hot (bad water pump) then dropped some valve seats and chewed one up. Block checked and honed. I bought the car from a coworker and rebuilt the motor. New reman heads
Expert:  sprinkles08 replied 11 months ago.

Where did the heads come from?

What was done with the block?

Customer: replied 11 months ago.
Heads only in Texas
Block was cleaned and honed. There wasn't any damage to the cylinder wall. Just one piston was beat up.
I can kick it down and it pulls good. I've put 700 miles on it since the rebuild. I also installed new MDS coils during the rebuild.
Customer: replied 11 months ago.
One more very important thing. This was happening at 200mi. As I was pulling into the driveway the car shut off and wouldn't crank. I was removing the intake to check some possible causes and saw another intake seat had dropped. No damage. Sent head back and got a replacement. Car fired right up but still had the same problem.
Expert:  sprinkles08 replied 11 months ago.

Are there any abnormal noises?

Customer: replied 11 months ago.
Maybe a light tic when its cold and has the misfire but nothing that seems unusual under the rough idle.
Expert:  sprinkles08 replied 11 months ago.

Does it run ok right after startup and then transition to running poorly?

Customer: replied 11 months ago.
Cranks with a rough idle smooths out when warm but surges under medium load. When I put it to the floor it kicks down and pulls strong. Stores a random multiple misfire and knock sensor circuit
Expert:  sprinkles08 replied 11 months ago.

Has anything been done to try to diagnose it?

Customer: replied 11 months ago.
Compression test- no
Fuel pressure - no
Swapped egr with no change
Map sensor swapped with no changeThe fuel rail doesn't have a test port and I haven't had any luck finding the right fittings to introduce the guage
Expert:  sprinkles08 replied 11 months ago.

Are there any modifications to the engine?

Customer: replied 11 months ago.
No. Everything is all stock.
Expert:  sprinkles08 replied 11 months ago.

Can you try driving it with the upstream oxygen sensors unplugged and see if anything changes?

Customer: replied 11 months ago.
I'll try it tomorrow and let ya know thanks
Expert:  sprinkles08 replied 11 months ago.

You're welcome!

Customer: replied 10 months ago.
I haven't had time to work on the car. I will try to unkook the o2 senor today and let you know. What is the purpose of this?
Expert:  sprinkles08 replied 10 months ago.

The purpose is to see how it runs without the sensors' signals.