How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: Chrysler
Satisfied Customers: 22371
Experience:  ASE Master & Advanced level certified, Chrysler Master Certified, Trans and Hybrid Specialist
9825021
Type Your Chrysler Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

ALSO I FORGOT, BRAKE LIGHT WENT OUT ALSO

Customer Question

ALSO I FORGOT, IM SORRY , BRAKE LIGHT WENT OUT ALSO
Submitted: 1 year ago.
Category: Chrysler
Expert:  Dan replied 1 year ago.

Hello, my name is***** year, model, make, and engine size of vehicle? Thanks.

Customer: replied 1 year ago.
2005 300C HEMI 5.7
Expert:  Dan replied 1 year ago.

Is anything else going on besides brake lights not working?

Customer: replied 1 year ago.
IT STARTED OUT POWER MIRRORS STOPPED WORKING, HORN STOPPED WORKING, BRAKE LIGHT WENT OUT , THEN TO 4 SECOND DELAY START AND IT WILL NOT GO OVER 30MPH
Customer: replied 1 year ago.
PCM IS NEW, JUST HAD TRANSMISSION SERVICED.....
Expert:  Dan replied 1 year ago.

I'm not sure what to think of this one, I'll open question back up incase someone else has ran into this.

Customer: replied 1 year ago.
ALL TCM AND SCCM WAS LOSING COMMUNICATION.....OK, THANKS
Expert:  sprinkles08 replied 1 year ago.

Hello and welcome to JustAnswer!

Do you know what fault codes are setting?
Where did the replacement PCM come from? Was it replaced for this problem or another issue?

Have all fuses been checked?

Customer: replied 1 year ago.
u0001-lost communication with tcm yes every single has been checked, every connector, The pcm was changed due to other problems we had late last year. the motor was mainly stalling when we got it fixed with a new pcm.
u0001-can c bus
po7o3
Expert:  sprinkles08 replied 1 year ago.

Where did the replacement PCM come from? Was it replaced for this problem or another issue?

Have all fuses been checked?

Customer: replied 1 year ago.
the pcm came from a parts store and it was for another problem we had a year or so ago and yes every fuse had been checked
Expert:  sprinkles08 replied 1 year ago.

Are the ABS and airbag lights staying on?

Customer: replied 1 year ago.
the abs isnt on but the airbag light goes on and off all the time
Expert:  sprinkles08 replied 1 year ago.

Do you have a code reader or scan tool that will communicate with the aribag module?

Customer: replied 1 year ago.
no i do not
Expert:  sprinkles08 replied 1 year ago.

Is the trans in limp in?

What happens when you attempt to start it?

Customer: replied 1 year ago.
the trans is in limp mode and when i put the key in to start it, i turn the key over and there is a 3 to 4 second delay before starting
Expert:  sprinkles08 replied 1 year ago.

Are you able to obtain an actual scan tool capable of communication with all modules?

Customer: replied 1 year ago.
no I'm not.....but it has been scanned a couple times and the codes I gave you earlier still come up. the person that scanned it said that there is power coming in and out of the modules....somewhere in between there isn't
Expert:  sprinkles08 replied 1 year ago.

I do understand that these codes are setting but there is far more than that setting, I believe a code reader was used just to check codes in the PCM, rather than an actual scan tool. It's going to take some in depth electrical testing to determine what you have going on and a full capability scan tool is going to need to be used.

Is there any corrosion evident in the power distribution center if you remove a few fuses and relays?

Customer: replied 1 year ago.
no, theres no corrosion
Expert:  sprinkles08 replied 1 year ago.

Do you have power on the pink/dark blue and pink/gray wires at the brake switch?

Customer: replied 1 year ago.
that I do not know the answer too. I just know the brake light does not work and I changed the brake light switch and it still didn't work
Expert:  sprinkles08 replied 1 year ago.

Can you check?

Customer: replied 1 year ago.
I actually do not know how to do that....I'm a girl that has learned a lot about cars but never really could get it with all the electric and power things.......
Expert:  sprinkles08 replied 1 year ago.

In depth electrical testing is going to need to be done to determine exactly what is going on. You most likely have a handful of problems.

You may have a bus communication issue or a loss of power or ground to multiple components. A loss of power would be most likely.You could have a wiring issue, internal failure in the integrated power module or power distribution center, and part of the issue may be the wireless ignition node. The WIN is a common cause of delayed starter engagement.

Customer: replied 1 year ago.
If the win is bad, could that bring up any codes to do with the sentry key immobilizer?
Expert:  sprinkles08 replied 1 year ago.

There won't be any SKIM codes unless the WIN isn't validating the key for some reason, in which case the engine would be starting and dying with the S***** *****ght flashing.

Customer: replied 1 year ago.
ever since ive had the car it has has skim codes but the car has been in the shop several times and the codes get cleared but that one eventually always comes back, but ive never had the engine dye with any s***** *****ght flashing
Customer: replied 1 year ago.
I honestly think that you have a very good point of one problem that no one has ever come up with yet and that is the win. but I'm pretty sure there is more, but the whole dilemma of all this is that it most likely started from one certain area or point in the system. at the moment my car is in the third shop it has been in, in the last two weeks because no one seems to want to deal with it or knows how to deal with it. where it is now is equipped with the kinds of equipment you mentioned and I'm sure that will be the first thing that they do. all three mechanics have said different things and I'm starting to wonder if I will ever be able to get my car fixed. I just recently finished modifying the looks of this car and will be deeply saddened if this situation is not taken care of.
Customer: replied 1 year ago.
jpeg
Expert:  sprinkles08 replied 1 year ago.

You definitely have more than one problem going on.

I would recommend a dealer over an independent shop if you've already had it to three. This is going to take some in depth testing and with a full capability scan tool, an independent shop isn't as likely to have the equipment or specific electrical knowledge.