How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Amedee Your Own Question
Amedee
Amedee, Chrysler Technician
Category: Chrysler
Satisfied Customers: 24413
Experience:  ASE certified Technician advanced level specialist. Wisconsin certified emissions state inspector
279429
Type Your Chrysler Question Here...
Amedee is online now
A new question is answered every 9 seconds

I checked both fuse#30. And#5. 5 was but still no blinkers..

Customer Question

I checked both fuse#30. And#5. 5 was blown but still no blinkers.. And#39 is not getting any power..
Submitted: 1 year ago.
Category: Chrysler
Expert:  Amedee replied 1 year ago.

Hello and welcome! My name is ***** ***** I can assist you with your question. Can I start by getting your VIN?

Customer: replied 1 year ago.
2C3JA53G15H616319
Expert:  Amedee replied 1 year ago.

Thank you for the VIN! One minute while I pull up your vehicle..

Expert:  Amedee replied 1 year ago.

These are the fuses under the hood correct?

Customer: replied 1 year ago.
Expert:  Amedee replied 1 year ago.

Well, fuse 39 will not get power until the rear window defoger gets activated. This is normal

Expert:  Amedee replied 1 year ago.

The issue your having is that the blinkers are not working correct? The front or the rear blinkers do not light up at all or they light up but just dont blink?

Customer: replied 1 year ago.
I okay.. No problem.. I still don't have blinkers?..
Expert:  Amedee replied 1 year ago.

Do the wipers work? What about the radio?

Customer: replied 1 year ago.
No blinkers, no horn, no wipers, no mirror adjustment!..
Expert:  Amedee replied 1 year ago.

Does the instrument cluster work?

Customer: replied 1 year ago.
The instrument cluster works..
Expert:  Amedee replied 1 year ago.

Thank you for that information. The reason I ask is because the instrument cluster controls these functions. They also get power from the TIPM which is located under the hood. The Integrated power module could simply be bad causing this issue.. which is very common. The steering control module may also be bad causing this issue as well. Start by disconnecting the battery cables from the battery for about 10 minutes and then hook them back up and see if that does the trick. Let me know!

Expert:  Amedee replied 1 year ago.

Two other possible causes could be a bad ignition switch or a bad clock spring.

Expert:  Amedee replied 1 year ago.

I would be willing to bet, if the module reset does not work, there are going to be codes in one of these modules I mentioned related to this issue. You might even find that one of these modules may not be communicating. It might just be a bad steering control module. IF this is the case, the module may need to be replaced.

Expert:  Amedee replied 1 year ago.

I am glad I can help! Please dont forget to honor your good faith deposit by rating my answer as "Excellent Service" for assisting you with your question.

Expert:  Amedee replied 1 year ago.

It has been a pleasure working with you! Have a great weekend and please dont forget to rate!

Best Regards

Amedee

Expert:  Amedee replied 1 year ago.

.

Related Chrysler Questions