How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: Chrysler
Satisfied Customers: 21573
Experience:  ASE Master & Advanced level certified, Chrysler Master Certified, Trans and Hybrid Specialist
9825021
Type Your Chrysler Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

Matt! Hope you can be my 2004 Pacifica expert! I have had

Customer Question

Hi Matt!
Hope you can be my 2004 Pacifica expert! I have had this car since it was a baby and now it has 156k miles on it. I have a few issues I want to take care of:
1) When in Park it shows all gears being selected, furthermore autostick doesn't work. Vehicle upon start up says memory system disabled (but car starts no problem so it must know its in park)
2) P0403 + P0032 - This has been recurring but I got it off long enough to pass inspection last year so I haven't gone further on this.
3) Navigation not turning on.
Submitted: 1 year ago.
Category: Chrysler
Expert:  sprinkles08 replied 1 year ago.

Hello and welcome to JustAnswer!

The PRNDL display lighting together may be due to the trans controller being down. If the TCM is actually awake then it has to be an issue with the range sensor, it's wiring, shift cable adjustment, or possibly an issue in the instrument cluster.

Does it show all other gears correctly but lights all boxes in park?

Does it actually shift into all four gears or is it stuck in second?

Has anything been done to try to repair the EGR or oxygen sensor issue?

Customer: replied 1 year ago.
Hi Thanks for quick response.It shows all gears when in park. In reverse it shows correctly. In neutral it shows all gears. In drive it shows correctly. Auto stick shows as D with no auto stick functionality.For o2 and egr I have not done anything yet. A damper on the main air plenum was broken... I ordered a whole new plenum. See pics... could that failure cause these codes?
Expert:  sprinkles08 replied 1 year ago.

The manifold tuning valve wouldn't be capable of causing the electrical issues.

Do you know if the P0403 and P0032 started setting at the exact same time for sure?
Has a shift lever test been done with a scan tool?

Has shift cable adjustment been checked?

I'm traveling today and will be unavailable for much of the afternoon, if you reply while I'm offline I'll get back to you as quickly as I can.

Customer: replied 1 year ago.
No... right now I have standard obd 2 bluetooth adapter with torque app on phone. Can I perform test with this?
Expert:  sprinkles08 replied 1 year ago.

Can you pick TCM from a module menu?

Customer: replied 1 year ago.
No my scan tool is a basic one that just shows me fault codes.
Expert:  sprinkles08 replied 1 year ago.

How was the range sensor wiring checked ?

Customer: replied 1 year ago.
This was a few years ago but I believe... I disconnected c4 and trs.... checked each wire to ground to rule out short... checked each wire for power... connect harness back to trs. Using c4 pin out and schematic go through gears and check the appropriate switch is closing.Would my regular odb2 scanner show transmission codes or do I need a drbiii?
Customer: replied 1 year ago.
Also... I remember using this to verify appropriate feedback at pcm.
Expert:  sprinkles08 replied 1 year ago.

Were the circuits load tested?

Customer: replied 1 year ago.
No... just continuity to ground
Expert:  sprinkles08 replied 1 year ago.

I will be unavailable for the next few hours,I'll get back to you as quickly as I ca!

Customer: replied 1 year ago.
Thanks, ***** ***** talk to you soon
Expert:  sprinkles08 replied 1 year ago.

You're welcome!

Expert:  sprinkles08 replied 1 year ago.

Have you double checked the range sensor connector terminals for corrosion?

Customer: replied 1 year ago.
No... but we had problem and in an attempt to fix we changed the trs... so trs wouldn't have corrosion. Even with new trs same issue...Obviously the car knows it's in park cause it starts, right?
Expert:  sprinkles08 replied 1 year ago.

The connector is what I was questioning.

Customer: replied 1 year ago.
Got ya! I will take apart this week and get back to you.Wouldn't I get a code p0705 if this was the case?
Expert:  sprinkles08 replied 1 year ago.

With the symptoms you're having I have little doubt that it's setting a range sensor code. The reason you're seeing the PRNDL boxes act that way is because the TCM is seeing an implausible combination of switch states from the range sensor.

Customer: replied 1 year ago.
Gotcha.. let you know after I pull plug off. Thx
Expert:  sprinkles08 replied 1 year ago.

You're welcome!

Customer: replied 1 year ago.
Pulled plug off. Looked good. Cleaned terminals and plug. Found broken ground, repaired, cleaned otger grounds. Re assembled. Same issue... however I noticed something.I shifted through the gears a few dozen times... each time it shows all gears selected in park... reverse shows good... neutral shows all gears... drive shows good... auto stick just showing as drive... now here is the interesting thing when I go backwards through gear neutral shows up! Every time!...Did it about 2 dozen times... then I was just shifting random gears, at a fast pace and shifted quickly from drive to park and it showed up as Neutral! After that neutral would not show up any more even shifting backwards.
Customer: replied 1 year ago.
Btw the park showing as Neutral only happened 1x... then shifted again and park and neutral show all gears selected all the time
Expert:  sprinkles08 replied 1 year ago.

If you pop the shift cable off the arm at the trans does the hole in the cable line up perfectly with the stud on the arm?

Customer: replied 1 year ago.
Didn't get a chance to do that yet. Would a transmission code show up via OBD2 scanner?Can I clear a transmission code without a DRB3 scanner?
Expert:  sprinkles08 replied 1 year ago.

Whatever you read codes with is going to need the capability of communication with the TCM. It doesn't have to be a DRB but a generic code reader isn't going to have the capability of looking at data or communication with other modules like a scan tool would.

Customer: replied 1 year ago.
Can you recomend one?
Expert:  sprinkles08 replied 1 year ago.

Do you have a laptop?

Do you have a price range you'd like to stay in?

Customer: replied 1 year ago.
Between 100-200
Expert:  sprinkles08 replied 1 year ago.

The cheapest way to go would be AutoEnginuity which is a laptop based system, which starts at $250. This is the closest you'll get to an actual scan tool and be able to monitor data and communicate with more than just the engine controller. An actual scan tool is going to be in the $2-3,000 and up range.

Customer: replied 1 year ago.
That's not a bad price. I was looking at witech vci pod on ebay which cost around $500.Do you know if the autoengiunity would allow me to program a new key for the car?Thanks
Dan
Expert:  sprinkles08 replied 1 year ago.

It doesn't look like it has the ability to program a key.

The WiTech is also a computer based system that you'd also have a purchase the software/license for but it isn't the ideal scan tool for your car. The DRBIII was the factory scan tool used with the older PCI bus vehicles, WiTech is designed for later CAN bus vehicles.

Customer: replied 1 year ago.
I am going to order the witech vci pod. Let you know when I scan car with it.
Expert:  sprinkles08 replied 1 year ago.

You did see my post about the WiTech?

Customer: replied 1 year ago.
No... but the witech does drb iii emulation.
Expert:  sprinkles08 replied 1 year ago.

It does, but you're still going to have to pay a license/subscription fee for the WiTech desktop client. Just having the pod won't allow you to communicate with the vehicle.

Customer: replied 1 year ago.
Ok I will double check with seller.
Expert:  sprinkles08 replied 1 year ago.

Ok.

Customer: replied 1 year ago.
Alright I got the scanner... posting results of tests.
Customer: replied 1 year ago.
1) I performed the following. Scan Engine for DTC = P0032 This code has been there for some time... I reset and and reappeared right away. See attatched data for sensors with engine running and engine not running.2) The car has suffered spurts of very rough idling almost to the point of stalling intermittently. I ran some actuator tests @900-1400rpm... at first the tests were doing going and then it started to go erratic. During the erratic idle I was able to film the rpms and engine noise... then during the filming I heard what sounded like relay chatter coming and going. It appears to be fuel leak detector pump... many years ago I had to run new wires to because the wiring harness was damaged.Actuator Test - https://youtu.be/TezWRuPtFFQ
Fuel Leak Detection Pump - https://youtu.be/ok8g1byAOHY3) Transmission - DRBIII scan showed a P0706 (Check Shifter Signal) this code didn't show with a regular OBDII scanner. Tried to clear code and it reappeared immediately. TRS has already been changed. Have had issues with failed engine mounts causing a rub on wiring in past. Replaced engine mounts. Next step is to run new wires from the TRS connector to PCM connector. What do you think?TRS Signal Test - https://youtu.be/8hRtBuJdwNo4) GPS Navigation not functioning SOLVED - Pin #1 had no power... ran new wire.Let me know your thoughts. Thanks!
Expert:  sprinkles08 replied 1 year ago.

The upstream oxygen sensor will need to be replaced with a Mopar sensor to repair the P0032 and driveability issue.

If the range sensor has been replaced and the engine/trans are properly grounded then you have a wiring or connection issue with the range sensor. You'll either need to load test each circuit or you can hard wire them if you want. If you go into the TCM with the DRB and move the shifter through each positioin while watching the range sensor switches you should be able to see which switch circuis never change state, those are the ones to concentrate on.

Customer: replied 1 year ago.
What did you think about the fuel leak detector pump in the video?
Expert:  sprinkles08 replied 1 year ago.

It's a natural vacuum leak detector rather than an LDP and I don't think that noise was coming from it. The only time there would really be any noise is if it's doing an intrusive leak test when commanded by a scan tool or while driving after a small leak test has failed overnight. It's hard to tell from the video but it sounded like the noise was related to engine speed and sounds more like it's coming from the exhaust.

Customer: replied 1 year ago.
Ok ordered the Mopar sensor. Let you know if it solves problem.Also I need PIN code to program key for this pacifica and an 07 grand caravan. Can you get me pin codes or should I start another thread?
Expert:  sprinkles08 replied 1 year ago.

It's against corporate policy to post SKIM or radio codes publicly or release them without verifying ownership in person. The parts department at your dealer will be able to give you the codes when you pick up the oxygen sensor.

Customer: replied 1 year ago.
Ok ty... let you know how it goes!
Expert:  sprinkles08 replied 1 year ago.

Great!

Related Chrysler Questions