How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: Chrysler
Satisfied Customers: 21570
Experience:  ASE Master & Advanced level certified, Chrysler Master Certified, Trans and Hybrid Specialist
9825021
Type Your Chrysler Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

I have a 2007 chyrsler town and country that the blower

Customer Question

I have a 2007 chyrsler town and country that the blower motor (front and back) stopped working. Discovered that the fuses aren't working (they aren't getting the spark they need). Could this be an issue with the Power module located behind the glove box?
Submitted: 1 year ago.
Category: Chrysler
Expert:  sprinkles08 replied 1 year ago.

Hello and welcome to Justanswer!

IF the front and rear blower motors stopped working at exactly the same time it won't be an issue with the front blower motor power module. Odds are you've lost a power feed to both blower motors.

The blower motors are powered by individual relays, the relays are turned on by the same driver in the front control module. You may have an issue with the front control module or an internal open circuit in the integrated power module.

I'm assuming the front and rear blower motor fuses are the ones you found had no power. When turning on either blower motor do their relays click?

Customer: replied 1 year ago.
Thanks, ***** ***** both go out at the same time, and they do not click.
Expert:  sprinkles08 replied 1 year ago.

You do have automatic temperature control correct? The control heads do power up and work?

Customer: replied 1 year ago.
I do not have automatic (I'm assuming that means that you set the temp- I just have a dial for cold to hot both in rear and front). The temp does change as it is adjusted - including air conditioning but the blower motors don't turn on. There isn't any power getting to the fuses.
Expert:  sprinkles08 replied 1 year ago.

You have a four position blower motor speed switch for each blower motor then, correct?

Customer: replied 1 year ago.
Expert:  sprinkles08 replied 1 year ago.

Do you have a test light to test at the relays?

Related Chrysler Questions