How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Vipertech Your Own Question
Vipertech
Vipertech, ASE Certified Technician
Category: Chrysler
Satisfied Customers: 1854
Experience:  11 years of Factory Dodge, Jeep and Chrysler training
3256298
Type Your Chrysler Question Here...
Vipertech is online now
A new question is answered every 9 seconds

I have a 07 Chrysler 300. After replacing the spring and

Customer Question

I have a 07 Chrysler 300. After replacing the spring and clip in shift assembly car won't start has check engine light on won't even turn over battery is fine fuse?
Submitted: 1 year ago.
Category: Chrysler
Expert:  Vipertech replied 1 year ago.

Afternoon. I have done this repair countless times and I know each step you went thru. There are a couple of connectors you need to make sure are plugged back in. There should possible have been one at the rear of the shifter close to where the left bottom corner bolt fastened to the floor. Then once you have the shifter out.....and about to seperate the halfs to gain access to the broken pink piece.....you have a connector that has to be disconnected at the rear of the shifter before the top half can be lifted off. Double check the connectors. Then if okay...you need to varify the shifter operation. You can install the repair piece incorrectly in relation to the shifter shaft and then you would have issues with no going fully into park or the key wont come out.....etc. Double check everything and let me know the findings.

Customer: replied 1 year ago.
Everything is plugged in and double checked there's three plugs all are plugged back in car is in park shifter works fine. But I now have a check engine light on and the red lightning bolt and car won't crank over. Checked power and about half of the smaller amperage fuses in the front fuse box don't have power. Could this be the ignition switch? All I did was the simple repair and plugged everything back in and now the car has lights and won't crank. Could I possibly have shorted something out?
Expert:  Vipertech replied 1 year ago.

yeah.....sounds like everything has been done right as you described. Being that we have a check engine light and lightening bolt now.....we need to check the codes. The codes will point us to the next step. Otherwise we checked the obvious which was the repair on the shifter. Now we have to pull the codes.

Customer: replied 1 year ago.
I plugged in code reader zero codes appear?
Expert:  Vipertech replied 1 year ago.
Lets try moving the shifter to the neutral position and see if any change.
Customer: replied 1 year ago.
No change reading zero codes then I checked and it had 3 u104 or something I didn't have time to write them down now it's reading no codes again. Why would this happen on such a simple fix? Any suggestions? Should I bring to dealer? I'm pretty mechanically inclined and cannot figure out why this would happen and why half of my fuses don't have any power. My ignition fuses aren't blown just no power to them when tested but brake fuse ac fuse etc have power to them
Expert:  Vipertech replied 1 year ago.

okay....lets try something different based on the fuses you mentioned. Maybe the wiring inside the console got pinched when the shifter was bolted down. Make sure the wiring is routed around the shifter. None the less......lets do this, find a few fuses that are in question.....let me know exactly what # ***** and if possible the fuse lid description. I can then check the wiring diagrams related to those fuses and see if we cant narrow down the search. If the code is U0104....then thats lost comm with cruise control module. None the less lets find some fuses as described and you make sure to double check the wiring harness that goes by the shifter inside the console.