How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris Your Own Question
Chris
Chris, Technician
Category: Chrysler
Satisfied Customers: 13368
Experience:  30 years certified Chrysler technician, smog license Certified Master Technician
12365498
Type Your Chrysler Question Here...
Chris is online now
A new question is answered every 9 seconds

Chrysler Pt cruiser: 2007 pt cruiser giving a p0344 code that

Customer Question

2007 pt cruiser giving a p0344 code that I can't get rid of. Checked timing belt and tensioner both are good. I replaced cam and crank sensor with mopar parts . I checked wires from sensor to harness.
I even changed the spark plugs because I read some where this caused the code so I decided to give it a shot. I don't know what else to do.
I clear the code and as soon as I restart the car engine light goes on and p0344 is back. Not sure what to do from here
Submitted: 1 year ago.
Category: Chrysler
Expert:  Chris replied 1 year ago.
Welcome! my name is ***** ***** I would like to thank you for allowing me to assist you!some of the causes for this code are 1 cracked magnet on the end of the cam where the cam sensor is, 2 aftermarket sensors (I recommend only Mopar sensors ) ,and 3, a broken cam gear dowel pin . Loose fitting terminals in the sensors connector can cause thisalso.
Chris
Customer: replied 1 year ago.
I used mopar sensors... I changed the magnet and checked wires from sensors to harness. How would I go about looking at dowel? Also I should mention the original code was p0014 I believe which was for the cam sensor. The car ran good but sputtered at 3500 rpm as long as I came off gas and let tranny shift it was drivable. It was not until I changed sensors that the
P0344code came up. I even changed spark plugs because I read on a forum that sometimes a misfire causes the code.
Besides the dowel pin I checked and re checked everything you mentioned
Expert:  Chris replied 1 year ago.
To check the dowel pin, you will need to remove the camshaft sprocket from the camshaft in order to check the dowel pin.
Chris
Customer: replied 1 year ago.
I really am at my witts end with this car. I doubt it's the dowel pin only because I wasn't getting the p0334 code until I changed the sensor because of the p0016 or 14 I can't remember . I will check the dowel just in case any other possible leads to go on.
Expert:  Chris replied 1 year ago.
Yes, at least rule it out. Chris
Customer: replied 1 year ago.
Can you tell me on the plug for the cam sensor there are 3 terminals or leads inside .. How many should have the 5v out of 3 ... Obviously 1 is ground but I'm getting the 5v on the other 2 leads ...
Expert:  Chris replied 1 year ago.
2 will show 5 volts one is the actual reference voltage, and the other is the sensor signal, and will also show 5 volts and is used for diagnostic functions.
Chris
Customer: replied 1 year ago.
I checked and rechecked everything I possibly could... The car starts but has the rev limiter at 2k rpm .. Is the cars computer being faulty a possibility . I can't afford to spend anymore then I already have . The inspection is up this month so I only have a few days left . I appreciate all your help so far if there is anything else you can think of please let me know .
I am at the car it's on the lift so I can try whatever you say . I have used 2 set of sensors which I can't get refunded because there considered electrical . The magnet inside cam, wires and plugs , I traced the wires from sensor to harness .. I really just don't know what else to do .. I'm pulling my hair out my head .. Please help
Expert:  Chris replied 1 year ago.
Besides that dowel, it can be the PCM. Let me send you the diagnostic procedure.
Chris
Expert:  Chris replied 1 year ago.
Copy and paste the link below into your brtowsers address bar and hit enter. Maybe this will help.
Chris.
https://www.dropbox.com/s/jgyix0360pnbndy/P0344.doc?dl=0
.
Customer: replied 1 year ago.
i appreciate all the help if i need to pay again i will. i guess i should start from the very beginning... I had a start up problem once or twice a few weeks ago . just cranking then i had 1 stall out . i thought fuel pump going. checked pressure on fuel pump all was fine. i thought ok maybe dirty gas .. couple days after the check engine came on for the first time. the car was drivable but would sputter at 3500. as long as i got off the gas and let tranny switch the car was drivable.
put it on scanner and got the p0116 which is cam sensor. went to dealer where they adviced changing out both. since i changed the sensors the code went from116 to 334 . i changed the sensors again and still the same code.
not sure if this info helps you to help me but like i been saying i am at my witts end... thanks again
Expert:  Chris replied 1 year ago.
Ok, well maybe you have a wiring harness or PCM problem, but hopefully the diag procedure will steer you in the right direction.
Chris
Customer: replied 1 year ago.
everything in the wiring harness checks out according to the doc you sent.. i went thru it step by step.
Expert:  Chris replied 1 year ago.
Ok, then that leaves the PCM or a dowel problem.
Chris

Related Chrysler Questions