How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask GM Tech (Cam) Your Own Question
GM Tech (Cam)
GM Tech (Cam), Chevy Technician
Category: Chevy
Satisfied Customers: 15181
Experience:  GM Grand Master Technician 2007. 14 years experience.
10949255
Type Your Chevy Question Here...
GM Tech (Cam) is online now
A new question is answered every 9 seconds

Ecm is senting high voltage code to ignition module in 2007

Customer Question

ecm is senting high voltage code to ignition module in 2007 uplander. what would cause ecm to send signal? Have replace ecm twice but still have the p0315 code
JA: Just to clarify, what's the exact code? And have you tried to reset it?
Customer: have reset it numerous times but still returns and car will not put gas into the engine.
JA: Are you fixing your Uplander yourself? What have you tried so far?
Customer: Code is p0315, p1682 and p2078. I have just replaced the ecm a second time and the high voltage is still coding. What would signal the ecm to send the high code to the ignition module to keep the engine from starting? I have finished the key security set up but can not do the crankshaft sensor because the car will not start. Battery good starter working.
JA: Anything else you want the mechanic to know before I connect you?
Customer: I have cleared all the codes and contacted the company that did the exchange on the ecm but they don't know why the high voltage is still going unless another sensor is signaling the ecm to sent the high voltage.
Submitted: 2 months ago.
Category: Chevy
Customer: replied 2 months ago.
History - this summer ecm went out. sent unit out to be replaced for used unit. same problem as now. Placed unit and had a mechanic reset crankshaft sensor. Uplander ran for 4 months then the same problem returned with the high voltage signal to the ignition module stopping the gas. Sent ecm back to company and they confirmed problem and sent me another unit. Upon replacing the ecm and running the security key I attempted to start it after clearing the codes. The three codes I sent you are the only three now and without starting it to set the crankshaft code I am stuck. What would send the code to the ecm to send out the high voltage signal?
Expert:  david craig replied 2 months ago.

Hi Im David, the ignition switch is what would be sending it. There are 2 ignition 1 voltage circuits supplied to the Engine Control Module (ECM). The first ignition circuit is provided by the powertrain relay, through a fuse. This ignition 1 voltage circuit supplies power to all the internal ECM circuits associated with the throttle actuator control (TAC) operation. The second ignition 1 voltage circuit is supplied by the run/crank relay through a fuse, and is used to power the remaining internal ECM circuits. If the ECM detects a voltage difference between the 2 ignition 1 voltage circuits, DTC P1682 will set.l

Customer: replied 2 months ago.
What do I test? Fuses first, Ignition signal next or do I just replace the unit? Difficulty replacing it? Does the drive shaft have to come down?
Expert:  david craig replied 2 months ago.

drive shaft?

Customer: replied 2 months ago.
opps steering column.
Expert:  david craig replied 2 months ago.

first of all what year, model and engine ?

Expert:  david craig replied 2 months ago.

never mind. 2007 uplander.

Customer: replied 2 months ago.
2007 uplander 3.9 reg gas
Expert:  david craig replied 2 months ago.

heres a table to start the diagnosis

Customer: replied 2 months ago.
It will be tomorrow before I can test the voltage. Can I get back with you then?
Expert:  david craig replied 2 months ago.

sure. right here

Customer: replied 2 months ago.
Thanks I will get back with you then.
Expert:  david craig replied 2 months ago.

you bet

Expert:  david craig replied 2 months ago.

do you still need assistance?

Expert:  david craig replied 2 months ago.

just checking in to see how its going