How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Auto Service Technician
Category: Chevy
Satisfied Customers: 24727
Experience:  14 years GM dealer Technician.
14928985
Type Your Chevy Question Here...
Pete is online now
A new question is answered every 9 seconds

A month ago I asked you about my rear view mirror where the

This answer was rated:

Hello again. A month ago I asked you about my rear view mirror where the compass and temp indicator stopped working. I checked the voltage drop and it is zero. So I bought a used mirror online and it doesn't work either. On both mirrors, the little green light is lit. Does that indicate there is power at the mirror? If so, maybe I have power but I have a loose connection at the other end of the compass and temp sensor wires.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

If you have a poor ground this can cause an issue with the compass and temp display on the mirror.If you can tell me what was tested/checked I can look up more info on this here just let me know.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service,your 5 star rating is appreciated.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Customer: replied 11 days ago.
Pete - I did get an answer from Tim last night and I tried his suggestion which was to disconnect the battery cables, hold them together for 10 seconds to re-boot the BCM, then reconnect them to the battery. When I did that, the compass and temp did show on the mirror for about 5 seconds, then went away again. So I repeated the process 3 more times and was not able to get them to work. So, I'm back to square one. Does this result give you any further idea of what the problem may be? Your advice is appreciated.

So I can look up the correct info on this model here,does this model have heated or memory seats at all and is the heater and ac controller manual or does it have the AUTO functions on it?

Let me know so we can continue,thanks Pete.

Customer: replied 11 days ago.
Pete - it has heated seats and the ac controller has an Auto function.

One more thing,what liter engine is in this model here?

Customer: replied 11 days ago.
5.3L

And when you tested the voltage drop was this between the power and ground signal that plugs into the mirror itself?

Customer: replied 11 days ago.
I had our mechanic check this. He was to check the voltage drop between the BCM and the connector at the mirror. His answer was there was no drop.

Do you have a test light or multi meter to test electrical with at all?

Customer: replied 11 days ago.

O.k.,disconnect the mirror and test for at or near 12 volts dc between the Pink wire and the Black wire at the mirror connector with key on and let me know what you come up with here.

Thanks Pete

Customer: replied 11 days ago.
ok. It'll be a couple of hours before I can get to that. but I'll let you know when I get it. THX.

Your welcome

Let me know what you come up with here when your ready.

Thanks Pete

Customer: replied 10 days ago.
OK Pete. Sorry for the delay. Had work to do for customers, then my multimeter went bad so had to get another one. Anyway I have 11.5 DCV between these contacts. Next ?

If you plug this connector into the mirror and jiggle the connector that plugs into the mirror does the compass and temp try and display then at all?

Customer: replied 10 days ago.
No. The only time it has tried to come on was after the first time I disconnected the battery cables, touched them together and reconnected. But they came on for about 5 seconds then faded away.

I apologize for the delay.

It is very possible the BCM has an internal electrical fault causing this issue here needing replaced.When replaced it has to be replaced with a new one as a used one will not work in your model as they have to be programmed to your model and cannot be reprogrammed into other models.

This is the only thing I see here that can be causing this fault.

Let me know if you need anything else and feel free to rate my help here as this is how I receive credit for my time.Your 5 star rating is appreciated

Thanks Pete

Pete and other Chevy Specialists are ready to help you