How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask GM Tech (Cam) Your Own Question
GM Tech (Cam)
GM Tech (Cam), Chevy Technician
Category: Chevy
Satisfied Customers: 15133
Experience:  GM Grand Master Technician 2007. 14 years experience.
10949255
Type Your Chevy Question Here...
GM Tech (Cam) is online now
A new question is answered every 9 seconds

I am having trouble with my heating I have no heat fan blows

Customer Question

I am having trouble with my heating I have no heat fan blows cold air changed radiator and cap removed heater core hoses getting no coolant from heater hoses changed thermostate also.Engine runs at 100 at all times.
JA: Have you checked to make sure the thermostat is working? What about the coolant level?
Customer: yes
JA: What is the model/year of your Chevy?
Customer: 1999 s10 extreme
JA: Are you fixing your S10 yourself? What have you tried so far?
Customer: all that I stated in my first message to you
JA: Anything else you want the mechanic to know before I connect you?
Customer: no
Submitted: 6 days ago.
Category: Chevy
Expert:  david craig replied 6 days ago.

Hi Im David, are both radiator hoses getting hot?

Customer: replied 6 days ago.
no
Customer: replied 6 days ago.
are you there?
Expert:  david craig replied 6 days ago.

yes

Expert:  david craig replied 6 days ago.

is one getting hot?

Customer: replied 6 days ago.
no both are cold
Expert:  david craig replied 6 days ago.

uper and lower radiator hoses are cold after the engine runs for a while?

Customer: replied 6 days ago.
Expert:  david craig replied 6 days ago.

is there any coolant in the system?

Customer: replied 6 days ago.
it is full
Expert:  david craig replied 6 days ago.

are you sure you arent talking about the heater hoses?

Customer: replied 6 days ago.
not the radiator hoses
Expert:  david craig replied 6 days ago.

so you are talking about the heater hoses?

Customer: replied 6 days ago.
Have checked radiator hoses they are warm but not hot
Customer: replied 6 days ago.
heater hoses are cold
Expert:  david craig replied 6 days ago.

you need to remove the thermostat, pull the heater hoses off the firewall, disconnect the upper radiator hose and flush out the system, you got a major blockage somewhere.

Customer: replied 6 days ago.
still with me?
Customer: replied 6 days ago.
have not heard from u since 10:35.
Expert:  david craig replied 6 days ago.

did you get my message? flush the system

Customer: replied 6 days ago.
have done that.
Expert:  david craig replied 6 days ago.

with the thermostat removed?

Customer: replied 6 days ago.
no not that way
Expert:  david craig replied 6 days ago.

what engine is in that? 4.3?

Customer: replied 6 days ago.
all I know 4 cyc.
Expert:  david craig replied 6 days ago.

ok.give me a sec

Customer: replied 6 days ago.
Okay
Expert:  david craig replied 6 days ago.

take the thermostat out and power flush the whole engine block. there is something blocking the flow to the heater hoses.

Customer: replied 6 days ago.
Okay. Thank you! We'll try that tomorrow.
Expert:  david craig replied 6 days ago.

let me know the outcome.

Customer: replied 6 days ago.
If this does not work will get back with someone tomorrow.Have a great night.
Customer: replied 6 days ago.
should I ask for u?
Expert:  david craig replied 6 days ago.

ill leave this open

Customer: replied 6 days ago.
ok thanks.
Expert:  david craig replied 6 days ago.

you bet. just make sure you let me know if it helps

Expert:  david craig replied 5 days ago.

checking in to see how its going

Customer: replied 4 days ago.
Hey David have not got to try anything yet the weather here is pretty bad but just has soon as it breaks will try what u suggested.
Expert:  david craig replied 4 days ago.

ok, thanks for letting me know