How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chad Farhat Your Own Question
Chad Farhat
Chad Farhat, ASE Certified Technician A6 - Electrical / Electronic systems A7 Heating / Air conditioning systems
Category: Chevy
Satisfied Customers: 3016
Experience:  Owner at Carolina Auto Service & Sales , 20 years Experience in Foreign & Domestic vehicles A6 - Electrical / Electronic systems A7 Heating / Air Conditioning systems
45790705
Type Your Chevy Question Here...
Chad Farhat is online now
A new question is answered every 9 seconds

My 99 camaro eill not stsrt

Customer Question

My 99 camaro eill not stsrt
Submitted: 6 months ago.
Category: Chevy
Expert:  Chad Farhat replied 6 months ago.

Hi, I'm Chad. Welcome to JustAnswer. I'm reviewing your question and I will be posting your reply ASAP.

Customer: replied 6 months ago.
Car will not start it sounds loke has no gas but it does
Expert:  Chad Farhat replied 6 months ago.

is there a check engine light on ?

have you had a diagnostic scan and retrieved the fault codes ?

We need correct Fuel pressure & good Spark for the engine to run correctly ?

Do you have a test light so we can check for spark ?

Do you have fuel pressure tester to check for fuel ?

are you looking at fixing this yourself or looking to know the most possible cause of this issue and taking it to repair shop for the work ?

Do you have any prior experience in electrical troubleshooting and testing with a test light for

have you checked all fuses and fuel pump relay

do you hear the pump come on when you turn ignition switch from off to on ,supposed to come on for few seconds

Please let me know

Thank You

Chad Farhat

ASE Certified Technician

Customer: replied 6 months ago.
When i press gas it feels like nothing
Customer: replied 6 months ago.
Like i pressing air
Expert:  Chad Farhat replied 6 months ago.

oh i see, you checked throttle body ,tb linkage , gas pedal iteslf,

so car cranks & runs but you lost throttle correct ?

Expert:  Chad Farhat replied 6 months ago.

v6 or v8

Expert:  Chad Farhat replied 6 months ago.

The throttle body for the TAC system is similar to a conventional throttle body with several exceptions. One exception being the use of a motor to control the throttle position instead of a mechanical cable. Another exception is the new design Throttle Position (TP) sensor. The TP sensor mounts on the side of the throttle body. The TP sensor is actually two individual TP sensors within one housing. Two separate signal, ground and reference circuits are used to connect the TP sensors and the TAC module. The TP sensor signal voltage increases as the throttle opens.

Customer: replied 6 months ago.
Ok i was driving car turned off while drive and notice the battery gage dropped tried starting iy turned on tjen turmed off did this three time same outcome
Expert:  Chad Farhat replied 6 months ago.

since now you mentioned battery gauge ?

1- check for battery 12 volts

Expert:  Chad Farhat replied 6 months ago.

in case linkage broke part #

Parts Information

OEM Part #Price

Throttle Cable/Linkage

Throttle Cable

Manual Trans

12556795$27.00

Contact Dealer for most current part and price information

Auto Trans

12557565$32.42

Contact Dealer for most current part and price information

Customer: replied 6 months ago.
Ok so i had some one give me a jump they left there card connectrd with jumpers for a while and still nothing
Customer: replied 6 months ago.
It just sounded like car had no gas
Expert:  Chad Farhat replied 6 months ago.

you need to test that battery , do you have an auto zone or advance ?

they check it for you and see if it taking charge

Customer: replied 6 months ago.
Ok thanks
Expert:  Chad Farhat replied 6 months ago.

you are welcome

we need to have a good battery ,test generator also ,then if we have these good we can go forward to what causing this.

sounds like alternator failed and battery died or just battery stop taking a charge

i hope that is it, at least that is what i understood from you ?

Please let me know if you need anything else

Thank You

Chad Farhat

ASE Certified Technician

Expert:  Chad Farhat replied 6 months ago.

hey how are you

Please don't forget to rate me before you exit since that is how we get compensated

Hope I was helpful to you

A 5 Star Positive Rating is Much Appreciated

This Post Will Stay Open for You To Come back and Ask me Any Follow Up Question You May have on this issue , even after you rate me

Thank You

Chad Farhat
ASE Certified Tedchnician